Materials Turn Black when Imported from Blender

Hello there,
I’m very new at Unreal Engine, so please excuse my lack of knowledge of almost everything. I’m importing models that were created in Blender. Each of them have their own materials that I created in blender (using the internal rendering settings, if that helps), as opposed to doing it in Unreal like everyone recommends. When I import the meshes into my scene, I can see the materials perfectly nicely, it’s all jim-dandy. But whenever I rebuild the scene, all of the materials turn black. What am I doing wrong?

You need a second set of uvs for lightmaps. Goto the scene data panel and under uvs hit the plus button. In that channel select your mesh and use lightmaps uv unwrap. When you import that to unreal goto the mesh editor and assign the lightmaps to the second channel and that should fix the problem. Also the reason people recommend using unreals material editor is because the engine won’t pickup on the settings you used for blenders renderer. Unreal compiles the shaders differently so whatever you see in blender is going to look different. Even colors will be off. So you can still import the materials but you should also bake a color ID mask and work on the materials in unreal.

While that did work, my mesh now has really… funky shadows. I’m not sure if it’s my sloppy geometry skills or if it’s something in unreal.

Yup funky about sums it up. To help further I would have to see the blend file, look at the uvs and how you have the materials setup and what you are trying to do. Before you exported did you smooth it because it looks pretty jagged and rough. That may be the issue.

Well, the game is supposed to be a low-poly sort of style, so I have to keep the jaggedness. Oops. I uploaded two files for you to look at. One of them is a game file in blender; I used the blender game engine to create the game first. The second is just the island that you see in the previous picture. https://drive.google.com/folderview?id=0B_b8eGtNPjRbeXZHOXUzRUxfeGM&usp=sharing

Ok here is a solution. I assume the triangle shadows came when you baked the lighting because thats when they showed up for me. So I thought to play around with the light settings. First if you dont have one put a lightmass importance volume in the scene. Then select the island and under lighting check the override lightmap res. bake the light again. Because you are going for a low poly style look you can afford to push up the light map resolution.

If this fixed your problem please chose it as the answer to close out the ticket. Thanks and have fun. Cant wait to see further progress on this in the forums!

After adding in all that you said that I should add in, I didn’t exactly get what you did. How high did you crank the light map resolution to? I couldn’t get the weird shadows to completely go away until I raised it up to 1100, which is large compared to the 64 that it started out with.

I’m am not honestly sure now. Funny thing. I always double check what I do. So I just doubled the lightmaps res by checking the override res and set it to 128. Baked the map then unchecked it, baked again but it didn’t revert. It stayed looking good. With 4.11 there are some changes with lighting that need to be looked into. It uses a model from Sony now and also has a new feature called portals, though I think that is more for interior scenes getting light from outside sources, I am not sure havnt read everything new yet. But keep playing around. Oh ya I also disabled indirect shadows and and cast shadows, for what you are doing you should have those off.

Is there some way that you could send me your UE4 file to me? I’d like to compare my file to yours.

Email me at Mattatlowlit@gmail. Com and I’ll send you a link to my drive.

Okay, I’m going to relay over everything I did in as much detail as I can in case anyone else has this problem. EyeDee10Tee has all the credit, though. In blender, I have two maps displayed in the object data tab. The first is the standard UV Map, unwrapped at defaults. The second is the Light-Map, unwrapped at defaults as well. I export my one object into a .fbx file, at default settings. I go into the Unreal Engine, and I create a new first person project with default content at maximum quality. I delete every object in the scene and the two volumes, leaving just the light source and skylight in terms of lighting. I import the .fbx file into the content browser section. I drag the object into my scene, and position it to where I want it to. With my mesh selected, in the right lower corner in the details section, I double click the icon of my mesh under the Static Mesh tab to open up the Mesh Editor. In the bar at the top of the screen, that has the save button as the button to the furthest left, I change the UV Channel from UV Channel 0 to UV Channel 2. I press save. I close out, and go back into the main editor. In the details section, at the bottom right corner, under the lighting tab, I uncheck Cast Shadow. I also check Overridden Light Map Res, and set it to 128. I add in a Lightmass Importance Volume into the scene from the Modes section at the left side of the screen. I edit it to fit my entire object. I then select the SkyLight, and at the Details section, under the Light tab, I uncheck Cast Shadows. At the top of the screen, at the bar that has the Save button at the left most side, I press Build. Now it’s all good.