Materials on 4.23 Landscapes disappear after Packaging - Bug?

To cut to the chase:

Apply most any Material to a Landscape in 4.23, everything looks normal and fine in the Editor. No errors or warnings or visible issues.
After Packaging with no warnings or errors, open the exe and the Material is missing and the Landscape has the default “nothing” checkerboard.

I noticed this after opening a 4.22 Project in 4.23. The Landscape was using the “Ground_Grass” Material from the old Starter Content, similar in complexity to the “Brick” or “Cobblestone” etc. Materials. No errors or warnings, rebuilt objects/lighting etc., and after Packaging the exe Landscape was the empty checkerboard. I tried many other Materials simple and complex, and same result.

Verified all this in 4.23 with a new Project and the default “Third Person” template assets.
Add a Landscape, raise it above the current floor so it is visible (moved the spawn point up as well for good measure). Apply the included simple “Cube” Material already on the floor and all static meshes. Looks fine in Editor, no errors/warnings. After Packaging the exe Landscape is once again blank checkerboard.

Made a new Material. Added the UE4 Logo tex to the Base Color. Applied to Landscape, looks like a sea of tiled UE4 logos. Saved, rebuilt lighting, all is well. No errors, warnings. Packaged again, no errors or warnings - And exe Landscape is once again blank checkerboard.

The ONLY Material I’ve gotten to appear after Packaging is the “UE4Man_Body” that is on the Mannequin. I have no idea what makes it special in 4.23 versus all other Materials. It’s all really over my head, I’m just doing due diligence detective work.

Anyone else seen this Landscape Material/Packaging problem? Please let me know ASAP and/or try it yourself.
I want to report this as a bug ASAP, assuming there isn’t a new “checkbox” somewhere you need to set so Landscapes will Package correctly, and that “Default” settings don’t work anymore for some reason on purpose in 4.23.

Thanks much,

I see someone just today reported the same bug! Beat me to the punch. Good to know, my detective work verified. :slight_smile:

Apparently it will Crash if it is a shipping build as well.

You should file the bug (it probably was already) anyway. They do care about backwards compatibility.

You need to be able to convert an old project and just package it, so if you can not it’s most definitely a bug regardless of checkboxes being unchecked or anything else really…

Thanks for chiming in. Today’s bug report UE-80016 pretty much stole my thunder and added it crashes during a “Shipping” build, even worse. So as my detective work concluded it’s not a legacy problem(thank goodness) but a real 4.23 bug it would seem. No other problems noted(I have seen) with a Development build and exe. Just the missing Materials.

Anyone else seeing it, please add your vote to bug UE-80016.

I just want to thank you for flagging it on here too - Now I know not to waste time porting to .23 for a while longer… It would really suck to port what I have there to try and publish just to find out I can’t :stuck_out_tongue:

Seriously. Landscapes that can’t package and/or publish with Materials. That’s a pretty huge problem. How did Epic miss it? Oh well.

Yep, I can confirm the bug. It’s happening on all of my 4.23 projects, even new ones started in 4.23

FYI fwiw it has been “fixed” and will appear in 4.23.1 according to the bug report page, whenever that rev. drops.

Hmm, at least for me it is still broken, even though this is supposed to be fixed in 4.23.1
Is this in some way related to VR development?
Seems I’m stuck at 4.22.3.
Will try the 4.24 preview 2 and hope for the best.

I’m working with the 4.23.1 version of Unreal, and the problem still persist.
My landscape material is good in the editor, but in a package build it seems dark without diffuse and just some specular.
FYI, I also work with an Oculus VR headset for this project.
I also tested with an empty scene with just a planar landscape with the same material and this is the result :

  1. Editor
  2. Packaged build

I have published 2 things both using landscape materials without issues.
are you positive the material you created is compatible with oculus?
the editor will show you errors or warnings if when packing a material it fails.
You just need to review the log to see if that’s what happened…

After some investigations, it seems to be indeed something in my project or in my material setup.