Materials not linking to mesh

I created a VR Project using the standard VR Template. Everything was working fine but now all of a sudden, I cannot load Marketplace Assets into the project without having material issues.
To clarify this, when I install asset packs from my Library into the project the material shaders appear to load correctly. But when you drag a mesh into the viewport, it appears as just the World Grid material. Even if the shaders load, it still stays as World Grid.
In the Content Browser, the materials look correct at first. But after you drag the mesh into the viewport the material then changes to World Grid material. Its like the link to the material is broken somehow.

Example packs are: “Ancient Treasures”. When I install that pack in other 4.26 test projects, no problem. But in my main VR project it does not work. Another example is “Modular Ruins A” and “Modular Ruins B”. Modular Ruins A loads ok but B does not! In the test projects both work fine.

I am at a complete loss as to how to fix this.
I have tried right-clicking on the material in the content browser, Asset Actions/Reload. Does not work.
Also tried Asset Actions/Validate Assets… and the message comes up… “Data validation SUCEEDED”
My project at this point is dead, I cannot continue so any help would be greatly apprecated!

I’m not sure what could cause your problem, but I would try making a very simple material in the material editor and try adding that onto the mesh. If even that doesn’t work, then at least you know it is some problem with the mesh rather than the materials (or vice versa if the material successfully gets applied).

Also, if you find out it is just the materials that are the problem (because your very simple material worked), you can open some of them up and see if they are using any nodes or settings that don’t work in VR from there.