Materials not appearing in Oculus GO

Hello, I launched my project multiple times to Oculus GO and every time materials were missing, even though they are there in-editor. All my materials contain just a base color.
Here’s the in-editor view

Here’s what I see through Oculus GO:

Does anyone know how to fix this?
Thanks in advance.

Did you ever figure this out? Having a similar issue now.

No Materials and lights when launching Oculus Go

I have the same problems with launching my oculus go…
I import my materials from substance source and build the lights.
In my viewport everithing looks fine but when i launch my Go, all meshes are dark.

Hope somebody has experience with this kind of issues.


If you switch your editor “Preview Rendering Level” (4.22 and above I believe) to "Android ES2, you should see similar results to what you’re getting in the HMD.

To compile Android GLE Shaders, you need an offline/external compiler found here:

…and as demonstrated by toggling your material “Platform Stats” in the material asset window.

After you’ve downloaded the offline compiler, just input the file path in your editor preferences to establish the compiler connection and deploy as normal.

Finally, if all else fails…check your number of dynamic lights. Mobile devices have hard restrictions on the number of movable lights. If you exceed the max amount, all lighting will be lost.

More info on restrictions here: Lighting for Mobile Platforms | Unreal Engine Documentation