Materials (instance) Not Loading

Hello. I am completely new to Unreal Engine. The closest thing I know how to use is Blender.
I am using a brick material from the marketplace that came in a free bundle called: “Megascans - Clean Bricks”.

Whenever I try to apply the “07_Red_Brick_Wall_2x2_M_thmlaejg_8K_inst” material, (circled in red), to any surface, it changes whatever I apply it to, to the grey grid as shown in the screenshot.
However, if I drag the flat material, (circled in cyan), it will show up fine but have no depth or anything.

Can anyone help me figure out how to get the realistic material to display on the surfaces I need? I am using version 4.25.

Any help with this issue would be greatly appreciated.
Thank you.

The fact that the cyan circled mat is called ‘…albedo’ is a give away. It’s only the bare color, so no, that will no look right.

What is the other material an instance of? I think you have something up with that master material.

Like I said, I am pretty new to all of this so I am not entirely sure if I know how to answer “What is the other material an instance of?”

But this is my exact process of how I got the material:

1: I went to the Epic Games Marketplace and searched for Brick Materials that were free. There will be an image attached that has the material bundle circled in red.

2: Once I downloaded it, I went to my Library and looked in my “Vault” and found the bundle. There is a button that says “Add To Project”. (In another image circled in cyan). When I clicked that, it gave me the option to put that material into my project.

3: After I added it into my project, I went to my project, looked in the materials tree, and saw the newly added “MS_CleanBrick” in my list. I went and found the material that was the closest thing to what I was looking for, “07_Red_Brick_Wall_2x2_M_thmlaejg_8K_inst”, (all of this indicated by cyan circles and arrows), and tried applying it to the front area that you can see is now grids.

I tried applying it two different ways. The first way was using a python script that applies that material to all of the materials with the same default material. (I’m sure you know what I’m talking about). And the other way was literally just clicking and dragging it to any of the surfaces, and neither of the methods worked. They both resulted in the grid issue.

That was my exact process for acquiring and using the material.

I hope that answered your question, or at least part of it. Let me know if you need me to show you anything else.


No, ok, sorry, that’s not it.

In your first pic, the name of the material has ‘inst’ on the end. That lets me know it’s an instance.

If you double click it, it will open the instance. You will see a lot of parameters, but if you scroll all the way down, you will find the material that this instance ‘derives from’.

Then double click that.

Theoretically you can continue this game forever, but typically, it will take you to the master material within one of two steps.

You always know when you’ve got there, because instead of those parameter screens, you get the actual material graph, which is a load of nodes connected by wires.

That’s the bit that’s not working correctly, so all the instances deriving from it will also be broken.

If you find that graph, could you post it? Will it compile? ( there’s a compile button top left ).

I did a bunch of searching for the Compile Button in the program itself as well as searched for help online but couldn’t find any direct answers so, here are screenshots of everything within the “master material” I found after digging into the “Brick inst”

Hope this is helpful!

Thanks again for the help so far!

The compile button in a material is the ‘Apply’ button top left.

If you move one of the nodes a bit, the apply button will light up and you can compile.

I’m assuming you don’t get an error.

Have you tried just putting a cube in a basic editor scene and just dropping you problematic brick instance on the cube?

Sorry this is taking so long, kudos for sticking with it.

Okay so I moved a node and hit apply. It seemed to have compiled everything without any issue. I’ll post a screenshot of the stats just in case though. If there is another way to “post” it though.
As for the default cube, I just added one in and applied the inst. material, and it worked. So I was curious if it was an issue with my UV’s or something but then I remembered that the Albedo works fine so, I don’t know how UV’s would be the issue…?

I built the house and everything in Revit, and exported it using the Datasmith method.

Thanks again for continuing to help though! I’M sorry it’s taking so long lol.

Ok, apparently when you apply that instance to your mesh and get the grey squares, if you double click the instance there will be a small red error in the preview pane.

That’s the window with the ball in, top left in the material instance.

Do you have anything there?

EDIT: Newsflash: Go to the master material and click on the background, this gives you the material detail settings. Trundle down to ‘crack free displacement’ and turn it off.

( and compile and save ).

EDIT2: I’m now 99.9% sure this is it. It would be absolutely typical for the brick material to have tessellation enabled, which requires this parameter. If this solution works, turn crack free back on, and under the build settings section, you’ll find ‘Build Adjacency Buffer’, tick that.

BOOM - the end?

Okay, I agree with you that we should be getting very close lol.

I went and disabled the “crack free displacement” and that made the material show up! So that’s fun!

However, I cannot for the life of me find the “build settings section, or ‘Build Adjacency Buffer’” anywhere. And obviously if I turn the “crack free displacement” back on, it goes away again.

I searched for “Build Adjacency Buffer” within both materials and under the Build button in the main interface. The only mentioning of it that I could find was on a Python Documentation page that only said “build_adjacency_buffer
(bool) – [Read-Write] Required for PNT tessellation but can be slow. Recommend disabling for larger meshes.

Lol. Feels bad man. But still so close!

So close!

It’s an FBX import option!

So what am I supposed to do? I can’t find anything that mentions “Build Adjacency Buffer” anywhere. And I’m not sure what to do with “It’s an FBX import option” lol

laughs while crying hysterically

One day, we will get there…

I found a somewhat vague post, it said ‘it’s in the build options on the asset’.

What I glean from this ( I’m not at a machine and can’t check ) is that you should be able to double click your mesh ( the one that doesn’t like the material ), which opens the mesh editor. In the mesh editor, I think there should be ‘build options’ and there will be something about ‘Build Adjacency Buffer’.

Fingers crossed…

Welp… it worked! Turns out literally EVERY single mesh has that same issue so I am going through very slowly and ticking that setting on everything throughout the model lol.

But that all seems to be working properly! Thanks so much for the help!

Bonus appreciation if you know of a way to turn that setting on all of the different meshes at once instead of one by one lol :wink:

Thanks again!

You might be able to do it. Click a bunch of them in the content browser, then right click and find ‘bulk edit with property matrix’, or something like that.

You can do it from there.

Please tick the answer if you think it will ( eventually after much reading ) help others :slight_smile:

All I see is a “Thumbs Up” button. Is that what you mean? I hit it regardless.

Up near the top of this thread I put the original answer. That’s the bit you can tick - thanks :slight_smile:

Okay I will make that the answer. Do you think you should add the other comment that I liked that mentions having to go into the mesh rather than the material for the Adjacency Buffer? Because that was the last piece of the puzzle for me haha.

I think most of the important parts are green :slight_smile: