Download

materials help

Hi,Guys! There are the same materials and models on the doors, when I add blueprint for the right door,why the material looks different?13.jpg

Did you rebuild lighting?
I guess the engine creates the Blueprint asset, then removes your static mesh and puts the BP in its place.
Thus you now have no static lighting built for it (yet)…

It has been rebuilt, but the problem still.
f4761456c3bd0eeaf579dafbb65e39666d63102a.jpeg

Checked you the World Settings / Environment Color? If it is black set it to a white/bright colour.

Hi samchung,

That scene is using only Static Lighting so there is no dynamic lighting that can be cast onto the door.

When you place a mesh in a BP by default it is set to “Movable.” If you want the object to be movable that is fine, but you will need to adjust the Volume Lighting Samples. This is the method for dynamic objects to be correctly lit (within reason) in a statically lit environment.

You can visualize the samples by going to Viewport > Show > Visualize > Volume Lighting Samples

Ultimately, to get better lighting for movable objects in a statically lit area you will need to increase the number of samples. You can do this by going to Settings > World Settings > Lightmass Settings > Volume Lighting Samples.

Default is set to 1. Lower the value to get better results. Using more samples will increase sample memory usage.

Docs: https://docs.unrealengine.com/latest/INT/Engine/Rendering/LightingAndShadows/Lightmass/index.html
Specifically look at the Character Lighting part. This will discuss how Volume Lighting Samples are used for movable objects.

I hope this helps.

Tim

Thank you for your helps,The door looks good when I set the Volume Lighting Samples 0.1,but there was another problem as the picture below.
2ed13caf988defcef3b8870c1eec96b7ae9c34af.jpeg

Are you pointing out the black squares? Those are the volume lighting samples that you visualized under Show> like Tom told you. Those are creating the ambient lighting for your door, but they don’t appear in game. You can just turn them off through that Show menu again.

I see I see,Thank you!