Download

Materials and Meshes Disappearing

I don’t know if this is the right place to ask, but I’m working on a game and for some reason after I save the project and return to the level the next day any progress I’ve done seems to be disappearing. I save what I’m doing, but then when I return textures are no longer on the static meshes and in some cases meshes are missing completely. Does anyone know a reason why this might be happening like if there’s a setting I need to change or something? Thanks in advance for the help!

That’s very unusual, especially if you are using the Save All menu item to save all your assets. Are you using version control or antivirus software? Perhaps an antivirus or antispyware is getting a false positive and deleting your project files.

when i first started this stumped me for a while, ctrl+s saves the level, ctrl+shift+s saves all

Thanks for the advice everyone, but the problem isn’t actually the save all features since I do that each time. It seems like there is a glitch in the level map somehow. If I place new textures/assets/etc into the level and then return to it later they disappear even if they have been there before the new additions. I created another level with all of the assets in it and that level isn’t experiencing the same problem. It’s a strange thing and I haven’t been able to find out why the problem was there in the first place. I think it’s just the level in itself that is problematic if that makes sense.

I’m having the same issue, except it’s only my water materials getting deleted and only showing the “checkered” look on my meshes and assets. I have no idea what is going on, but I think it started after installing a water plugin for 4.26 version. I found out that everytime I click on my water material that I want to use for a spline just literally disappears. I can use other materials, but only all my waters don’t work for some weird reason.