Material vanishes when camera is far away

I currently have a massive object (5 km x 5 km) with a material. The material renders perfectly fine (albeit at very low quality) when close up; but when I get the camera far enough away to see it all at once the material starts flickering and then just vanishes.

I am using the default top down character so you can see how far out the camera is.

Any help on finding a way to force the material to stay visible?

Or is it because there a built in unchangeable distance that materials stop rendering at?

I have just found a possible solution, if you set the texture plane’s Z scale to a high number the material can be seen at large distances.

Although this doesn’t help with 3D objects (since they would then become very tall and distorted), can anyone help there?

Maybe your object has automatic LOD and that creates the mess. Try disabling this checkbox in asset window, and rebuild the scene again.

I currently have the texture applied to an actor and can’t find the menu you have shown. (isn’t that menu only for static meshes?)

I have also found that applying the texture to a static mesh that is big enough to see that far away doesn’t have the same problem as I stated above and works (mostly: the texture isn’t mapped right) flawlessly.


Static mesh is is placed in the space with actor, you can change the static mesh properties assigned to the actor, by clicking here :


Double click on the static mesh thumbnail and you will get the same window as I got in the first screenshot.

You may look into the documentation for UE4 from Epic, like there :

Sometimes its hard to find what you need in those documentations, but all in all they are comprehensive guide to the UE things. I know that UE allows you to jump into the engine and start having fun, but all in all, it is a complicated engine and you will need a manual for sure.

Thanks for showing me that but sadly changing the LOD doesn’t help any.

Adjust the “Bound Scale” up on Rendering in the Details Section on the Mesh or Object.

1 Like

This was the answer for me

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.