Download

Material transparency issues, creating shadows for masked areas of mesh

Hi,

I have a camera attached to the socket of a character, I would like to make the head and neck transparent so that no back faces are visible in first person however I would like the mesh to still cast the same shadow as if it wasn’t masked.

I have tried masking the head/neck through the material but that gets rid of the shadow for the head/neck when I observe the shadow on the ground.

Has anyone had this issue and found any solutions.

Thanks in advance.

You could try leaving some opaque geometry inside of the neck and head, set the mesh to be hidden but to cast hidden shadow.

Thanks RyanB that worked really well, I was unaware that there was an option for that.

I’ll mark this one as resolved, but I still have a minor issue.

I have added the head and attached via a socket with the lighting settings you suggested however I have a slightly different shadow type for the head compared to the body.

I have provided an image to illustrate:
cf5cb19a80c7ffe026e5e197b8462e86b5d6d1d3.jpeg

Is it that the skeletal mesh (body) casts a different shadow compared to a static mesh (head).

That may be because you need to set the attachment to be shadow parented. Looks like the smaller bounds are causing a sharper shadow. I think there is an option for shadow parenting somewhere under the component settings.

Thanks again RyanB that was spot on, I’ve learnt a lot form this issue.

Marking as resolved

Cheers