Download

Material showing obvious seams from substance to UE4

My material looks fine in substance painter; however, whenever I export the textures and set them up in UE4 (doing it the same way i always do) I end up with a horrible seam. I did a test and exported the textures into blender and everything looked just fine as well. I am unsure as to what could be causing the issue as it seems more like its related to lighting? Its not the normal map (assuming) as when I saw out the normal with something else or nothing the issue still persists. The seam runs up from the thumb to the end of the arm but heres an image at about the same angle

Substance: Screenshot - 35d731f71b2d02571fd3e1ed3beadad8 - Gyazo
Blender: Screenshot - 9e00be84438644e0ef53fe043dc86b70 - Gyazo
UE4: Screenshot - dc87fec31b7ddb522e313439dd9cf4af - Gyazo
Screenshot - 91344d6d267c67bb2c437a7e2bd5fa10 - Gyazo

Make sure your normal map is using normal map compression in UE4

Is it. I dont think its a normal map issue but i could be wrong.

That harsh of a seam is usually an export with a sharp edge, or spliced geometry.

You can completely remove a sharp edge by using the exact same vertex normal of one seam on the other seam.
If for some reason the mesh can’t be whole, that is an important consideration.
Otherwise, merging one vertex onto the other.

the best way to check if the issue is the geometry or a material is to put a fully back or white (not specualr) materal on the mesh.
If the seam is still present you know that the smoothing group is off.

Should it be the material, first make double sure that your UV is properly split - with parts that are far enough apart.
second, make sure that your texture has a spill area that matches the same color overall.
usually you take the last pixel around the texture and stretchit out.
Repeat the same for the normal map, roughness, AO or any and all textures. Sometimes the seam is from something silly like the sub surface profile or the opacity (sub surf scattering).

Third, if you still aren’t happy with it, which is possible, you can bump up the values of the UV precision, as well with the values you can change on LODs or FBX import that deal with precision.

Aslo (not for OP but for the usual whiners), saying “blender doesn’t do it” doesn’t mean a thing. One is a DCC meant to work on high details, the other is a game engine. Even bumping up the detail you can’t really expect the same kind of rendering. In real time nonetheless.

Just tried with both a completely black and white material and the seam goes away entirely. I tried again by unwrapping the mesh again (without moving any of the islands around) and made sure there is no overlap or any verts going out of bounds (there was none on the old one either), then with using a different single smart skin material in substance i exported it out to UE and the same issue occurs where the seam is horrid.

I’m having the exact same issue. Texture looks fine in Painter, but the seams are super visible in UE. I know the UVs are bad on mine because I just did flatten by angle on a model I downloaded (I’m texturing with tri-planar and i do not want to deal with UV mapping the horrible geometry). Doesn’t explain why the seams appear in unreal when they arent there in Painter though. Tried the same stuff as gokitty, pure black and white material there is no seam whatsoever. I’ve tried various repacks and bakes, I’ve split into a few material IDs to give it more UV space, still isn’t fixed

Are the face normals pointed correctly? The rendered result looks inverse of what you’d expect…
it could be an issue with the actual skin material you are using btw.
and/without could have multiple UV maps.

the faces are pointing out correctly, just did a test with a completely gold material in substance and i have the same issue. is there any files i could give you that would help narrow down the problem? im at a loss right now.

If you don’t mind sharing the blend file, that would possibly be best.
However, before you do. How are you exporting the FBX?
using my plugin, if you properly set the shading to smooth and remove hard edges you can quickly click the export faces button which selects the proper export options with correct smoothing group.
http://mosthostla.com/gamedev/bonebreaker/
example:

Your post just appeared…
in ANY case where a black or white material shows no seam, the issue is the material and not the geometry.
Maybe the way Substance is importing the material is what causes the visible seams? or perhaps the textures just aren’t being imported correctly like it was originally suggested (with a normal map not being imported as a normal map).

@gokitty199 This looks like a lighting seam, most of the time, this is because the green channel of your normal map needs to be inverted.

I’ve used your addon a few times! subbed and bookmarked that video as thats something i need to learn as well lol. PMed you the .blend. Ive tried with both smooth and flat shading with the same results. heres my export settings: Screenshot - 5396832e6860ec24cde6e5196a37540d - Gyazo

tried flipping the green channel, same result

As I opened the blend this is what I see…

Looking into why…
So, the screenshot above is the result of the Tangent Space normal (of an invalid image).

There is nothing wrong with the model except that it isn’t manifold. meaning you need to close the top up so that light cannot sneak in and incorrectly light the mesh.

You need to have a look at the material, and how you are using the normal.
Why is Tangent space a requirement to this normal map instead of world?
Are you applying the same conversion within UE4’s material? if not, then you’d see the seam assuming that no seam is visible in blender with the setup I received.

I didnt think about closing up the tops, ill be doing that. for the material in UE4 im doing this. in blender i just threw it together (im not experienced with shaders in blender so i just connected it up)

Try using a normal map made with just 8080ff the default flat value for it.
Also review the settings for the material, is it using Tangent Normal?

same issue occurs with a flat normal at 8080ff. i tried with Tangent normal both checked and unchecked. checked gives the result in the images posted before, unchecked seems to have the same issue plus some others like so: Screenshot - a33afe22230038f516b7dc1e58300440 - Gyazo

Ok. let’s blame the material and make a skin material from a source that somewhat works.
Download and open the DigitalHuman sample project

Within it, migrate the skin from the bust. it’s a rather complex material and you need to simplify it.
Mine is customized beyond recognition at this point. however the important part is the settings you get on the material.

Surface, Masked, Sub Surface Profile, SSP_TwinBlast_Skin_Bust profile.
Tangent Space Normal should be checked (default I believe).

Along with the base noodle mess.

The important parts to keep are the Pores, along with the fernel mask, and the high end normal that get placed in.

To this material you will take the UV, and the Normal and “Derive Tangent Basis”, outputting the result into “tangent output” node.

This is the normal map Before the pores and the additional changes are processed.
Macro normal, normal strength, and mask modulation should be following it.

Personally, I convert textures to texture parameters, name them, and manage them in the instance so that I have a “master material” to go back to.

this is how your model looks with my test material.

This is the material i placed on it (not my default master skin)

This IS my master material, with a bad normal map for your unwrap (that’s someone’s neck beard :P)

As you can see the seam, is on top of the arm. or near where the actual seam is.

This is generated by a normal map that isn’t meant for the model.

PS:
in Digital Human you have M_Head and M_Bust.
Derive stuff from M_Head as it’s a bit more simple of a material.

Ill give that a try, what I’m not understanding is whats causing the issue and why its with several materials. This is what I’ve always done without issue for all of my meshes and materials

Skin can be tricky. But I really don’t see anything wrong with the model or the normal, or the in-game mesh, so the way substance is painting the mesh must be what’s wrong.