Material Shader Error x3004 and x3014 with VertexColor node

After converting my project from 4.9 to 4.12, there is a material with vertex painting that I can’t get to work.

I’m receiving the following errors in the stats:


and these with the shader debugging on:




The problem seems to happen only when I connect the VertexColor node (replacing it with any scalar value doesn’t throw the error), in order to use vertex painting. This is the shader (MF_Dirt is a material function using a bool switch, a WorldAlignedTexture node, and texture samples - no more screenshots available):

If anyone can help me make heads or tails of this, it would be greatly appreciated!

I’ve discovered that changing the MatLayerBlend_Standard node to MatLayerBlend_Simple does NOT throw the error, though the result is not what I need it to be.

Edit (worked around): This bug still exists, so I won’t mark it as resolved, but I have worked around it by using the Simple blend and manually recreating the blends for the pins I needed (it was just the specular pin that I needed)

Hi Grogger,

We have a ticket in already with this particular error X3004 that was submitted with UE-31792.

Thank you for reporting.