Material refresh/rendering issue 4.9.1

Hey guys,

I’m encountering a very strange material bug, when an object is moved in front of a tiled background (that has lines, so like a repeating grid) I can see the material rendering the lines back. It’s almost like the refresh rate isn’t fast enough to re-render the material back to the screen after the object has passed over it. I thought maybe it was my texture or my material set up, but I’ve replicated it using Epic’s own supplied tools

Below is a couple of images I took, it’s harder to see in stills. You can replicate the issue by opening content examples, start up the “Level Design” map, literally put any object you want into the scene, and just move it around in front of the walls.

If anyone knows how to fix this, or if it is an engine issue please let me know.

Thanks in advance.

1 Like

Hey ColonelVirus,

This could be a post processing issue. Would you mind typing the following command, ‘ShowFlag.PostProcessing 0’ into the command console to see if this fixes the issue?

I tested this issue on my end and am not seeing the same thing you are reporting.

Check to also make sure you Engine Scalability settings are at Epic, and your Material Quality Level is set to High. These options can be found under the ‘Settings’ dropdown menu in your main viewport window.

Thank you,

Hi andrew,

Thanks for your reply. Looks like it was the post processing issue, I entered the console command as you said and that fixed the issue. Does the console command completely turn of post processing? As in I now can’t use it at all if I wanted too use it for something else?

Engine Scalability was set to Epic as well.


Well now that we know it was the Post Processing, we can go into your Post Processing Volume and edit the exact feature or technique that is causing this issue. My first guess would be to change your AA settings within the Miscellaneous section of the Post Processing to FXAA.

To answer your question, the console command I gave you does completely disable the post processing in your project, but you can use a Post Processing Volume and edit the particular values within to get the desired look and feel you would like, instead of just disabling it altogether.


Cool thanks Andrew.

To be honest the post processing volume was the standard one that came pre-built in the 3D Side Scroller template. I believe I might have zeroed out motion blur, which could be why I could see this happening. As motion blur would normally blur the background as the character moves around. Ill take a look through the post process volume settings tomorrow see if I can workout the direcr cause. I understand even if everything is turned off, the post processing volume still adds certain things?? Or was that changed?? Like motion blur was set to zero and off, but was still added until I manually zeroed it out.

Hey ColonelVirus,

You are correct there are default Post Processing settings enabled by default when you create a new level. These can be disabled by going into your Project Settings and unchecking the specific options you wish to disable for Post Processing.

Let me know if you are still having issues and I will be glad to continue to help.


1 Like