Material refraction not working

Hi, I have a problem of making refraction effect in material. I followed the official document to implement refraction, set the Blend Mode to Translucent and Lighting Model to Surface Translucency Volume, but no refraction occurred.
It just looks like flat glass. I am using Mac, but I don’t think it is the platform problem. Can anyone give some solutions ?

1 Like

You have to put a fresnel node in there ( and a base color ):

1 Like

I did try that, still doesn’t work. I don’t think the fresnel matters, because it just affects the camera view angle. I also followed another tutorial showing that creating those two nodes only still gets refraction, but it looks flat glass on my computer. I don’t know why.

put it on a cube in the viewport, you can’t really tell in the preview…

1 Like

Here, all I did was this:

Only other change was to make the material translucent.

Put it on a cube:

1 Like

Honestly I tried all possible approaches to make it work. Still no use, no refraction at all. It is very strange, I watched a tutorial that even the refraction value is 0, it still gets some effect. If there is no effect in preview, it won’t work in the game scene as well.

I think it is a bug for Mac, maybe doesn’t support macOS Catalina. I did exactly the same thing but can’t get it. This problem also occurs in UE4.23, and reinstalling UE4.24 doesn’t help. I will keep it in mind. But anyways, thanks.

I have vague recollections of setting up UE on a mac ages ago. Did you install the metal library, or whatever it’s called? ( It’s a recommendation, but UE runs without it ). You need that…

1 Like

I recall having to download metal ( or whatever it’s called ) from the apple store.

I know that affects the graphics.

1 Like

I just looked it up, XCode it’s called.

1 Like

Metal is originally integrated in Mac, I believe. And I have used Xcode for a while so it is installed already. C++ classes and blueprint classes work fine in UE, other rendering stuffs like texture panner, normal maps are normal, but not for refraction.

Hmm, sorry. Out of ideas… :0.

1 Like

Never mind, I decide to leave it there to see if it will be fixed in UE 4.25.

I don’t know other necessary support libraries, so far the rendering works fine except for this small issue. UE already supports metal, isn’t it? What kind of recommendation would be?

The solution is stupidly easy. Changing the scalability to High/Epic solves it.


Thx ! It worked !

To be more accurate, its the effects quality that has to be set to high, not all the quality settings in the scalability of the engine, just the effects will do. Even reflections and shading can be set to low and it will work. Thanks for the help guys.