Download

Material Reflection is bad and flickering. (UE5) Lumen

Hello All,

I tried and searched everywhere for this but couldn’t find an answer.
Can anyone support me with ideas to stop the flickering. its very visible on the white marble floor.

I tried to use different materials, and change reflection from Lumen to Ray tracing or GI but nothing help.

Video to explain issue you can see here:

1 Like

That environment is absolutely beautiful, how did you make it?

Weeeird, never seen that before, looks like a bug.

1 Like

Thank you, its a work under process, Using Blender, with Unreal Export plugin.
But I kind of worried at this point, if I couldnt fix this issue, I might lose the project.

The scenario is so beautiful, maybe lighten up the reflection capture by adding a point light will solve the black side in it?

1 Like

Changing reflection from lumen to ray tracing won’t help. You need to first enable hardware ray tracing support, then set Default RHI to DX12, and then tell Lumen to actually use ray tracing.

The rendering settings in UE5 have became a bit of an overwhelming mess so newbies have no chance of using them properly.

  1. Enable hardware ray tracing
  2. Tell Lumen to use HW ray tracing
  3. Tell Unreal to use Ray Tracing instead of Lumen for reflections
  4. Tell unreal to use DX12 RHI so Ray Tracing actually works
1 Like

Thanks for your support.
But still not working, I don’t know if its me, it does look a bit better though.

I would really really appreciate some more ideas., I have a very big project, I tried to do Unreal Engine 4, its just too much time consuming to start all over there. not to mention quality was really bad, Lumen works like magic, this is my first project ever using Unreal Engine, I never tried UE4 yet.

4K updated Export:

Your reflections still seem screenspace. They could be overriden by some postprocess volume in your level.

Indeed, Reflections in PostProcessVolume Reflections were on Lumen. Now I am using Raytracing
But now I am not happy with quality of colors and shades. it look pretty dull, is there something as a newbie I am missing?
Does that mean Now I have to bake the light? I am getting a message of 49 unbuilt items?
Do I need to add

Some gentleman on YouTube propose to add this code (r.D3D12.DXR.AllowEmulatedRayTracing = 1)
to DefaultEngine.ini (Which you find in your Project Folder/Config/DefaultEngine.ini
I think I managed to add, but I didn’t see any difference.

Updated Render: