Material Not Compiling

Hey all,

So i’ve got a sofa set up with 3 materials, that can toggle between them all, however only 1 of the 3 actually compiles correctly, the other 2 appear in the grey checker pattern.

I’ve also set up another chair that toggles its visibility to cycle through a number of posistions in the room, this entire chair appears in the grey checker pattern.

I’ve tried re-compiling them etc. but no luck. Has anyone else experienced this/know how to solve it?

1 Like

Same problem in UE4.26

I imported a foliage mesh, placed the mesh in the scene with the foliage instancer, set a material in the instancer, works perfectly in UE (Engine) but once I package the project, that specific mesh is grey, no materials.

This may not be the issue as materials can fail to compile for multiple reasons, but sometimes the material usage flags don’t get set correctly and you need to go into the material and set them manually.

Figuring out exactly which one you need can be tricky but you can usually deduce it from what you’re trying to do with it.

An example: I have an local outline material that I have set to hidden inside of blueprint actors, when the player hovers over it the mesh unhides itself to provide an outline. After building lighting, the outline mesh would show up as a grey checker pattern indicating the shader failed to compile. Enabling “Used with Static Lighting” on the material solved the issue.