Material Flicker


There are a few old questions around this problem, but it still seems to be not resolved.
I’m sending the project with two car parts that are experiencing this issue.

When zooming in and out, there is a lot of flickering.
First I thought that shader is the culprit, but using even an ordinary mat displays the same error.
The bottom part is using plastic mat and the part above, chrome.

I tried to disable MIkkTSpace tangent, also unwrapping the part as someone suggested, but it didn’t help.

Is this the anti aliasing problem? Using different quality settings for it also didn’t resolve anything.

I would really appreacite if you could help us out with this problem, as this is very important to us.

Thank you very much.

[link text][2]

Is it z fighting? Are there multiple polys almost on top of each other.

Hi Harry,

I am not sure how to answer to this question, but the polys are not on top of each other.
Yes they are pretty close and the mesh is very dense, but as you can see per image below, there is no extra polys underneath them.
I just tried to delete a few faces to see if there is anything left by any chance.

Thank you.

Downloaded the project and at first it seems like it’s an aliasing issue but after looking at the back of your mesh I see there is additional geometry to create a closed mesh.
I think it’s aliasing and would suggest adding a LOD without those grooves modeled in.
But because of the geometry behind those panels it could be a depth sort issue since they’re so close to each other it causes the appearance of Z fighting even though the geometry doesn’t technically share the same space.
Delete those rear faces and test for the flicker.
You might even be able to make a LOD without the closed back?


I forgot to mention that I have tried to delete back faces already and that didn’t help either.
I have modeled very fast one piece that is just a plane with grooves (on the left) so the geometry is much cleaner. The flicker appears even for that piece.

This has been a problem for many years now (based on posts from other people), but I was hoping that it would be addressed in new versions of UE4.

If there is no other option except using the LODs which doesn’t help in our case, that is a very bad news.

I’m not an expert, but for some reason it seems to me that this is a display resolution issue. My case, for example: I have a tile texture for my floor, and everything normally looks fine, but when you look at it from a very low angle, all those lines representing spaces between the tiles get too close to each other and start flickering since the display resolution is just incapable to show them properly. Your geometry is really tiny, and you’re trying to fit about 30-40 lines in 20 or so pixels.

Will a user be able to get really close to see all that geometry? Maybe it would be better to a material with a normal map, where you can change anything depending on the distance to camera?

Again, I’m not an expert in rendering issues, so you can ignore all the above =)

Hi Tuerer,

Thank you for the input, but using a normal map is just not possible for our use case.
Also, user will be able to get that close to examine it properly.
The flickering appears on the edge of the second piece where mesh is not that dense.

It would be nice if this issue can be resolved within UE4, whatever this is, or just establish a correct reason why is this happening.

Thank you again.