Material Change Blueprint Random Errors

So I have set up a blueprint system in my loft scene that enables me to change materials on the walls and floor. using 3D widgets placed in the world.

(See Attached )

Side wall its materials with color, back wall and floor its materials with textures.

Now the problem is , It works, then it doesn’t, then it works again, then after resting it stop working , but not all buttons, there are some that work some that don’t.

It happens randomly and werildy,

Sometimes the entire side wall which is materials with just color don’t work.

The other two which has materials with textures, some buttons works, the other buttons show the same material on two buttons.

All this is just randomly, sometime sit all works properly.

Pls can any one help me figure out why this happens.


Hard to say with just these, you would need to bug test a whole project. but off hand, check and make sure that the input is received and that the settings for sending/receiving input are all the same with the same priority.

Hi, @MostHost_LA** , How to I check the input like you have mentioned ?? **

also, i packaged one yesterday, its works except for 1 button, today in the morning i check the pakaged.exe , it works except for 1 button, then after a while i ran the pakaged.exe again but this time 3 buttons on the side wall wont change, then i ran it again now 2 buttons change to the same material. can a pakaged.exe have such behavior ?

Possibly. it depends on how the level is loaded into memory and what has precedence on input.
check the blueprints of the items, in the detail section, under input.