Download

Material blur

Hi guy’s

Working on an urban theme map and immediately get very blurry lines?

http://s23.postimg.org/wcaa0uld3/Capture.jpg

http://s15.postimg.org/58n266s2v/Capture1.jpg

Is there a way to fix this ?

Greetings,

what is your mip map setting in the texture properties? looks like it is using bilinear instead of anisotropic. In fact that is is exactly what that looks like. For it to be anisotropic it should be using the “default” setting since there is no aniso option.

system info, such as GPU may be useful as well if that doesn’t affect it.

The sidewalk texture was not mipmap so I changed the resolution and now it is good.

http://s14.postimg.org/4whg2tlyl/Capture3.jpg

The rest seems to be world blur, i have a gtx 560ti perhaps the settings are to low.

most likely, anisotropic mip maps are disabled for low… try increasing the settings.

Basically with bilinear mips, the amount of blur is “Square” and has to be chosen based on the most extreme angle. So the road needs to be VERY blurry on the axis going away from the player, but not that blurry on the axis crossing the road. With bilinear, you have to use the max one for both sides since the blur is isotropic. So this over-blurs the axis that doesn’t need it, which is why your stripes get so wide in the distance.

For anisotropic, it actually performs a different amount of blur per-axis, so the ‘across the road’ vector has its own mip value not affected by the otherone.

The stripe material you have is about the worst case for showing the problems with bilinear filtering. It may be that you get a quality increase by using a higher resolution texture, or by using floating geometry to define your lines.

Hi RyanB,

http://s14.postimg.org/d84gvylil/capture9.jpg

On the right MipValueMode there was no mipmap level in the material properties now it’s next gen for sure.

Thanks!