Download

Material Blending - Mesh Distance Field Issues

Hi all,

After a lot of researches I still can’t figure out what is not working with my Mesh Distance Field Material. I’m trying to blend some rocks with the landscape material. However I got some weird shadows / lights issues ? Not sure what’s really happening though.

I recently found this free Material Blending given by Victor A. on Artstation: https://www.artstation.com/artwork/9zRna which is exactly what I’m looking for.

I’m using UE4 4.23, also tried on 4.24 and this is what I have at this point:

Images:

I’ve well followed the settings rules mentionned by the author as:

Hopefully someone can help me with this.
Best regards,

Why would unchecking “Affect Distance Field” work? I think it is keeping it enabled that allows the proper shadow to be projected / generated by the static mesh and distance field. In addition, try enabling “Two Sided Distance Field Mesh Generation” and / or increasing the “Distance Field Resolution Scale” up to 2 or 3, if not higher. It appears that a part of the surface of the stone is not getting shadowing, which could also be due to an inadequately sized / shaped distance field mesh. So, one other fix for it is to use World Displacement on the distance field mesh’s vertices to enlarge it and shape it to cover the entirety of the object or a little bit more than its entirety.

Thanks for your time Presto.
I tried to play with the values you mentionned above and nothing happened. I even tried to rebuild the light after each modification.

Do the mesh needs UV2 or something ?