Material Billboard Occluded


I have tested both Material Billboard and plain Billboard and there seems to be some inconsistency between the two types. Specifically, say I placed either billboard directly in the center of a sphere (perhaps to simulate the rings of a planet facing the camera for example) the material billboard will never ever show where as the plain billboard does.

I am assuming that because the origin of the billboard is within the planet the billboard is being occluded, I have fiddled with collision types to try and make sure the billboard is always drawn but it never seems to work for the material billboard.

Additionally, the material billboard stops rendering if its origin is no longer visible, regardless if some extremity of its surface is still visible, a fix for this would also be great!

I just wondered if anyone could help figure out what may be causing this inconsistency?


Hi Maddius,

You can adjust the size of the billboards by going to the Menu tab in the top left > Edit > Editor Preferences > Viewports > Look and Feel tab > Billboards Scale.

The default size is 1.0. you can adjust it here to make it smaller or larger.

If this doesn’t resolve your issue feel free to post images to be emphasize what could be improved.

Thank you!



Thanks for the reply, I mean the MaterialBillboard (as in the component) that you can add within the components tab, as far as I understand you are referring to the billboards the represent objects within the editor for example lights or player start.


I’ve looked at it in a Blueprint with the billboard sprite and the material billboard and I’m not seeing the same effect you are getting. I may not be setting it up the same as you though.

Could you post an image or video demonstrating what you’re having an issue with and I’ll see if this is something that needs to be addressed or can be adjusted within blueprints settings for billboard scale and size.

To repro:

  • Create a Pawn blueprint
  • Make the root component a static mesh which is a sphere
  • Add MaterialBillboard as a sub component of the root component
  • Scale the MaterialBillboard so that it should show as a plane intersecting the sphere

MaterialBillboards don’t behave the same as normal Billboards in this scenario, it’s definitely to do with the scaling of the MaterialBillboards bounds since if I select ‘Use Attach Parent Bound’ then the billboard shows for as long as the sphere is visible.

Is is something like the bounds aren’t correctly copied back CPU side? Are MaterialBillboards expanded on the GPU?


Thank you for the clear repro steps! I was able to see issue that’s happening between Billboards and Material Billboards.

In the material billboard if you select the option under the Rendering tab in the details you will see the last option is “Use Attach Parent Bond.” This will allow the material to use the parent (in this case the Sphere) bounds. It is suggested that this is a better optimization for using multiple objects in a blueprint.


Thanks for the reply, I did mention this work around in my other post, however It seems a little hacky to me… Surely the billboard should have to option to resolve its own bounds correctly? I understand that the option for parental bounds for large numbers of billboards would be useful, but it might be nice to have the material billboard have correct bounds in itself.


Ah, you did mention that before. oops! :slight_smile:

I’ll submit this a bug report as it would seem they should be acting the same without having to have the parented bond.


Hi there,

Is there any progress on that bug report?

For reference the JIRA is UE-4725 and it’s on the To-Do list, but a fix has not been submitted yet.

I’ll update this post when there is any progress. I’ve also bumped the community interest in this, but this is not an indication that it will get done more quickly, just that there is interest in seeing this resolved by multiple users in the community.