Material Based Tree Placement

I made an Auto painting terrain material with forest creation based on greyscale maps.
I’m using the ‘Landscape Grass Output’ node for this but trees get placed into others.
is there a way of preventing this or do I have to use Blueprints for this ?

Hey BurningSky,

All you need to do is reduce the Grass Density a little bit, and either change the ‘Placement Jitter’, or uncheck the ‘Use Grid’ option within the Landscape Grass Type asset.

Landscape Grass Type

The areas I have highlighted are your areas of interest. Let me know if you have other questions.


Thank you for your Reply,
unfortunately this solution doesn’t help me because I’m using multiple types of tree assets.

Sorry for bumping in, but I couldn’t find how to make this in first place, auto painting a map with foliage. Do you have a link?

Check this out