Download

Material Allignment Issues

I’m trying to do a floor with the basic polished walnut floor material. The First time I did it i was able to hit Alignment/Align Surface Planar and it sealed up the seam like it was supposed to. After tons of work later I was doing a run through and cleaning up stuff and i noticed a seam between my two wood materials. Now for the life of me no matter which planar setting I hit, align surface default-align surface planar-align surface planar wall-align surface planar floor-alight surface box-align surface fit, it will not clean up that seam. It doesn’t even change the material what so ever. I can pan and rotate all i want but there is no way i can get it to look seamless. Can someone tell me why my planar button is doing nothing and how i can fix it.

Are all your textures seamless and sizes are power of 2?

Idk, kind of a noob here. I used one of the basic textures that comes built in the engine. As for the power of two i have no idea what you mean. What I dont get was that it was working fine seamless until I saved and reloaded later and the seam came back and wont go away now.

So I guess you’re using BSPs?

I might be wrong but I seem to remember when working with BSPs that when they overlap they can affect the material alignments of each other. Try getting the seams correct, then converting it to a static mesh. Then carry on with the other elements of your level.

power of two → U and V should have the same size e.g 127x127, 512x512,…
Btw, take a look at this thread (same problem): Aligning the Texture dont work - Rendering - Unreal Engine Forums :slight_smile:

127 is not power of two.
Power of two means that texture size is 2^x where x is positive integer.
Width and height does not have to be same.

Is it the type of material where you could use WorldPosition-XY instead of UVs? That will sidestep all alignment issues.

Make sure to disable the “tangent space normal” option on the material if you use that.