Download

Masked Material + World Aligned Textures = No Baked Shadows

I have been attempting to cast a shadow onto a floor using a light through a plane which has a wire mesh material on it, the mesh is done with a opacity mask. I have set the material up to work with world aligned UVs to make it easier as its used a lot across my level.
The problem is, when previewing the lightmass the shadows appear fine, but when lighting is built they disappear as if there is no mesh at all. So I tried removing the world align node and just using the texture as the opacity map, and it worked fine. So I am thinking Lightmap shadow baking does not work with World Aligned Textures?

Pictures below might explain better, both are taken after building lighting

This image is using a setup without world aligned textures, just a simple alpha map hooked up to opacity mask
b1a57480680b130506928716a3379de904c58713.jpeg

This is the exact same setup, except with the textures set to world aligned
62b8d70b2d01f7e500b4f7409bee4ec8a08596fb.jpeg

If your mask is stored in alpha channel, then you should enable Export Float 4 in world aligned textures settings, and use respective component mask on its output to get your mask.

Thanks for the reply Deathrey, I have re exported my JPG as a TGA with the mask in the alpha channel, and in unreal material editor added a bool set to true from the WorldAlignedTexture Node, however there is no difference, have I used the Node correctly?

0cff566be8acfb57602ea27e1dc119589a8fb1af.jpeg