Making foliage popup from further away , not close

Hello I just bought the forest pack for the unreal engine. When I walk through the forest, the poping up of foliage is pretty close. I tried playing around with the culling settings but I have not been able to fix it. How can I make so that it pops up further away? What setting is usually changed?

Do you mean the lod’s or the culling (that it disappears)? :slight_smile:

Hi Malospam,

If you need to adjust the LOD distance you do the following:

The LOD distance can be set for each LOD in the Static Mesh Editor.

There is the option to set the Screen Size for each LOD. This is a value that works best form 1 to 0.

1 would be the base mesh that is the highest detail.

Lower level LODs would need to be set at a lower value. Using something like 0.5 would mean that when the mesh is at half it’s screen size it will change to this LOD.

If you think this is a culling issue (meaning the mesh has been removed from the scene entirely at a specified distance) you can check the Foliage Tool settings for the instances in question.

When you open the Foliage Tool and select the mesh you will see an option that says “Show Instance Settings.” There will be a section labeled “Culling.” If the default values for Start and End Cull Distance are set to 0 this is default and should not make the mesh disappear at a distance. If there is a set value here try using a higher value. For instance. If the End Cull Distance is set to 1000 this would be 1000 cm (unreal units) or 10 meters that it will be removed from view. Try using a higher value here for a longer distance.

Let me know if either of these doesn’t solve your issue.

Thank you!

Tim

Thanks Tim, I will work on it tonight and let you know!

Thanks Tim I solved the problem. I went to the instance settings and I saw they were all set to 0 and 500. I changed the 500 to 0 for all of them and that fixed the problem. thanks again!

Cool! Glad that worked. If you’re using a lot of instances, do consider using some culling to help with performance. Using a higher value will help make it not as noticeable versus using the lower value which made it easier to see them being removed and added.

Good point, thanks I’ll take that into consideration. I forget sometimes that I’m using a buff alienware machine. Good stuff man, I appreciate it. Btw, one reason I wasn’t able to see the instance settings was that I did not stretch the tab wide enough, so the button was covered up. Now I’ll be more careful about that, though I with maybe the developers could add something when buttons arent seen like maybe a visual like">>" or something like that. I hope that makes sense!

I don’t use the foliage tool too often, at least not on a regular basis, but I think this has been redone to make things easier in 4.8 on our internal build. This is also the build that is available on GitHub Master Branch. I typically only use our internal build when testing a bug to see if it’s still happening or occasionally looking at a new feature. I don’t use it for any projects or on a regular basis. I work mostly off the latest Binary build from the launcher just like everyone else. :wink:

A lot of the stuff demoed in the Kite World GDC demo is showing off the focus of Large Worlds in UE4. Some of the tools were updated to better handle this and got a face lift in the process.

Thats great to hear. I wish I could compile or a user could compile 4.8 and offer latest builds. Sounds exciting to hear though!

This doesn’t seam to work in 4.81 anymore. With a default min=0/max=0 culling settings foliage still disappears at a distance of about 200 meters. More specifically the whole cluster disappears.

You may have to use a “per-instance fade node” in the foliage material and hook it up to opacity.

I did, no result. It either hard capped or it’s just a bug in 4.81

Solution is in this thread: