Download

Making a green screen background in UE... weird vignette effect

Hi Folks

I’m a bit puzzled about getting a pure green screen background for AfterEffects compositing.

Even with an empty scene in Unreal

  • all lighting deleted
  • no atmospheric fog
  • all post processing deleted in ‘Edit Project Settings’ and camera settings
  • the green-screen material is perfectly green, unlit, and emissive (no lighting will affect it, no shininess, no shadows)
  • for the moment, there is nothing else on the screen… just big green cube covering the whole screen
  • lightmass run

Here is the thing… it looks ok visually, but when I put it into AfterEffects, Keylight 1.2 takes out all the green, and the image should now be transparent (because green was the only thing on the screen). However, there is always a subtle dark vignette effect around the edges. The centre of the still image / or image video sequence looks fine, brighter than the edges.

The same thing happens whether I do the render from inside the editor or from Matinee ‘movie’, and it is identical if I take a single screenshot or if I render a BMP or PNG sequence.

Has anyone got any suggestions please?
Thanks!

In Unreal…
Unreal.png

In AfterEffects (after Keylight)…
AfterEffects.png

Adding a post process volume and setting the vignette to 0 may override a missed setting.

thanks cDub :slight_smile:

I added the postprocess volume, then went in and activated the relevant Scene Color settings (scene color tint, fringe intensity, fringe saturation, vignette intensity) and then set them all to zero.

This seems to have worked. Yay!

I guess I had assumed that - when they weren’t activated- they defaulted to zero, but I think I was wrong.