Make textures/materials of BSP not change scale with scale of BSP

Is there any way to make textures and materials of BSP not change scale with the scale of a BSP?

Currently when I scale up BSPs the textures will also scale, making the textures look either small or upscaled. I guess this depends on the material, but I can’t seem to find a setting to wrap/repeat instead of stretch (it does not stretch currently, but it looks abit like stretching).

Hey Prantare,

Thank you for noticing this issue within the Editor. I have submitted a bug report to our developers. If for any reason you need to reference this bug report, please refer to: UE-12019

In order to get around the material/texture skewing when morphing the BSP, you can simply go into the ‘details’ panel of the BSP face you’re on, scroll down to ‘scale’ and select ‘apply’ which will then revert the texture/material back to its original value.


Thank you!

The temporary fix works.

Whenever I rebuild the lightning, the textures scaling become erroneous again => I have to click apply on each material manually. Any other quick fix for this?

Hey Prantare,

Unfortunately, I haven’t been able to find a work around for the materials scaling once you hit ‘build’. However, I wanted to let you know that this issue has been fixed and it’s waiting to be implemented in a future release. Currently, it says it’ll be released with 4.8, but I’m not quite sure how ‘set-in-stone’ that is.

Let us know if you run into any other complications and please let us know if you find a work around for this issue as well, as it would help many people in the community.

Thanks! :slight_smile:


I can confirm that version 4.7.4 fixes this issue - no more resets after building! :slight_smile:

Thank you for verifying that 4.7.4 fixed the issue. We very much appreciate it!

Cheers! :smiley:

WoW! I am new to UE4 and this bug confused me a lot! Thanks for the workaround info. BTW: Is there a way how to achieve similar effect with a Static Mesh object? (without manually changing UV)? Thanks

Hey Elijen,

Are you experiencing trouble with static meshes and their UV’s? Or are you simply asking if there is a way to change the size of the texture on a static mesh?


On 4.10.2 I face the same issue. I drag a box BSP on the level, set the M_Water_Ocean on it (from the starter content). When I scale the box the water material gets stretched as well. I was not able to find an option in the Details of the box which can fix it. (same happens with a cube static mesh and with Shape_Plane etc) I suppose I could fix it by changing the material but I feel there may be a simpler way. Is there?

UE-12019 is backlogged at this time and set as a priority of ‘4’. This means that any priority bug that is entered between 0 and 3 will take priority over this bug.

If you have any further questions, please submit a new post on AnswerHub!