Download

Make Skeletal Mesh Morph Effect In Niagara (with Animation Sequence)

Hello everyone.
I made a tutorial what Niagara in 4.20!
You can know a way to make Morph Effect with Skeletal Meshes in this.

Link to Tutorial Video(Youtube)

And now, I want to help one who has a problem, with this tutorial.

This Topic is for them.
That’s all.

Hey~ I am the man who followed your tutorial in youtube, and this is my issue. I’ve send two pictures, my “NMS Morph Update” is not like yours which can change some others. Thanks a lot

Hi!

Hmm, I looked at your module as “Module StartMesh”, in photo 01.
maybe, The point is, the issue is you didn’t use a namespace.
You should use ‘.’.
So You repair from “Module StartMesh” to “Module.StartMesh”, and from “Module EndMesh” to “Module.EndMesh”.

I will help you if you get hit with a problem, about the tutorial.
That’s all, thanks.

Yes!!! It works perfect now! Thanks a lot~ looking forward to see your next Tutorial and Project~

Thanks for your tutorial, it help me a lot <3
Where can i download the official Niagara Content Example?

Hi.
The official Niagara Content Example is contained Content Examples(“Niagara” level in Maps folder).
So you can see the examples in the level.

Please check out below.

Screenshot1-2.jpg Thank you for this tutorial! It’s amazing! However, I’m getting stuck around minute 20. (I’ve tried twice already). My StartMesh and EndMesh seem to be mixed up and the beginning of the sequence looks like there are multiple skeletons.

Really sorry for replying so late.

Maybe it has a problem in “Color Module”.
Color Module’s R channel control the morph from “StartMesh” to “EndMesh”.
If you fill other than ‘0’ or ‘1’ in R channel, you should fill like below picture.


​​​​​​​
If this solution is wrong, I want to check your making Niagara assets.

Hello, I’m on the 4.23 version and I don’t see the Mesh Component Update Flag (5:52)… do you know where is it now? thanks for the tutorial!

MeshComponentUpdate.jpg

Hello!
I was following the tutorial too, now is under the Optimization tab.

Arigatou gozaimasu!

Hello ! Thank you for the tutorial !

Everything was working for me until the step after programming the NMS (19’) Then, when I add the skeletals in the Niagara Emitter, nothing appears :frowning:
I’m on the 4.25.3 version, and I tried to adapt the NMS with what I got (photo 1)

Do you know what could be the problem please ?

Thank you