Make fog come from outdoor, not indoor

Hello, I have an indoor level that has windows in it. I added a exponential height fog to give a snowy day effect so when the player looks out the window, he/she will see a snowy/foggy day. The problem is when I add the fog, the fog is applied indoor as well. How can I apply the fog only to the outdoor environment? Thanks

1 Like

Exponential Height Fog has a parameter called “Start Distance”


If your building rooms aren’t too big, you can just set a start distance that is just a bit larger than the distance across your biggest rooms. For example, if you have a room that is 800 centimeters across at it widest part, you can set the Fog Start Distance to a value like 850.

1 Like

I was so stupid. Yeah thank you, I later found out about the Start Distance setting. Just what I needed

Great! You may want to mark the post as the accepted answer in case anyone else comes across this in the future :).

FYI, if you’ve got very large interior areas, I’ve seen some games dynamically increase the Start Distance value higher when the player goes inside, and then put it back when they go back outside. I’ve noticed that this is what they do in Witcher 3 when entering/exiting caves. Sometimes, the change is very abrupt in that game though.

I was about to comment then i saw the above answer. Thanks it resolves my issue too. upMarking it :slight_smile:

what if you want a fog only inside a room and not in the outer world ?
why is there no end distance ?