Download

Make emissive object emit even when offscreen?

https://youtu.be/illhj3ZTRBI

The video I uploaded to YT shows the issue pretty clearly.
I’m using emissive objects to light dynamic scenes, but the emission is always linked to the amount of the object visible on camera.
How can I change settings so that emission is always constant and not linked to object visibility.

Pretty sure what’s happening there isn’t the object emission changing but eye adaptation kicking in.

If the object is culling you just need to increase its bounds.

That said,
In the latest engine things have changed. Its no longer LPV based, or they included lpv into the regular system, so what you are experiencing could be a new limitation.

With LPV this effect was caused by the eye adaptation…
Start there. Disable it and see if you solve it or if it still happens.

Thanks for the reply, I kind of moved on from that project, due to the nature of it all being dynamic with dynamic bounced lighting too.
But when you say eye adaptation, do you mean ‘auto exposure’?