Make actor visible through walls?

I was planning on adding a mechanic to my multiplayer project that would allow players, under certain circumstances, to have their silhouettes show through walls, similar to HRV in Blacklight Retribution or the effect shown at ~35 seconds in this video of Gotham City Impostors.

Does anyone know how something like this is accomplished? Obviously I would be doing something to the character’s material, but I’m not sure what would make them render through walls like that. Is it a trick with the level geometry or is there a way to just force the actor to render “in front” of everything else? If this is possible in blueprint I’d prefer a blueprint oriented answer, although I’ll understand either way.

Thanks in advance.

He post his tutorial here

I copied the settings from this tutorial as exactly as I could, but I’m simply not getting any desired results. It makes certain objects invisible, and other objects the default normal checkerboard.

Can anyone reproduce this? Is there a setting I might be missing? I checked the post process volume and it’s enabled. Should I be combining this new material with another one?

All I did was copy the material editor settings, copy the collection parameters, and apply the material to a box and some other objects, checked render custom depth (and tried without) and set the bounds to 10 like in the guide.

I’m also interested in getting more details about this. At the risk of highjacking your question, I want to render occluded actors as well, but simply use their existing material instead of the wireframe-type material in this tutorial.

You dont apply the material to an object. It is a post process material so you use it in the Blendable slot of your camera/volume’s post process. You will see the effect on the meshes you enable custom depth.

I want the reverse. I want occlude walls, like old isometric games. Maybe a cone from camera to actor. But I dont know how do this on material editor.

Did you find a solution to your problem? I am facing the same problem as you. I want the object to be visible with its original material even if behind another objects.

Hi Jacky, I don’t know if you remember much about this but do you think you could point me in the right direction with this?

I can achieve what he does in the video at 0:45 using post process, but I can’t seem to figure out what I need - the effect at 1:20.

I just need to be able to see my actor behind objects but after following the tutorial I’m not sure how to make it work.

I would really appreciate any help, thanks a lot

Same here. I just want to make a customDepth object visible behind walls, but with its default material. Anyone?