Major - Unable to matchmake into a UEFN project with 5 or more players

It’s still an issue for us and we’ve hammered Epic with reports. I’m sure they’re aware, I feel your frustration.

2 Likes

@Rory_REDGamesCo @AxelCapek Just wanted to let you know that we are absolutely aware of these issues and while we didn’t get fixes into 24.00 (as you’re aware) they have fix versions for the next release.

2 Likes

Still happening in 24.01

@AxelCapek discovered that by replacing the IslandSettings device some autogenerated settings will be recalculated and might allow you to fix this issue. Please try re-adding an IslandSettings device to your project.

Edit: As it turns out you might not need to entirely replace the island settings device. Just toggling an option in the island settings should recalculate the generated fields.

Can confirm this was the fix for us!

We are still unable to play in 24.01 but it is a different fail that may be related to our process. Just seeing a friend in their UEFN session and selecting “Join Game” from their profile results in a matchmaking error.

Can someone write a step by step guide on how they are connecting to another UEFN island and playing?

Do we have to “Publish Project” or “Upload a Test Code”?

Do we need access to the “Creator Portal”? We are still access denied

Rory

Multiplayer issues are now resolved for us now that we have access to the Creator Portal.

1 Like

This issue is very much not solved for me, even with access to the Creator Portal, which I was excited to hear of as a potential workaround to this problem.

I’ve released a Private snapshot of my island, which has successfully made it through the review process. I then loaded up the island in the Fortnite client using my account, proceeded to invite another person for the purposes of playtesting.

After we both were marked as “Ready” I was successfully launched into the island/match, but the other individual received the same error they got when we were attempting to playtest the map prior to creating a private snapshot (through the UEFN client). The error reads Matchmaking Error #2: you cannot play this game mode at this time.

Additionally, thinking that something in the settings was only accepting one client connection at a time, I gave the private island code to the other individual in an attempt to see if they could launch and join the island themselves, just as I had. They could not. The same error appeared when they attempted to launch the private island in a lobby of just themselves.

This, unlike the OP’s problem, is occurring with just two people: myself, the creator of the island, and another individual helping me playtest. What am I missing here? Do I have to create a fully discoverable version of my island that is very much in the non-finished testing phase? I’d like to avoid that if at all possible, and it definitely seems like it should be.

@amedhurst Thank you for your report! We would like to look into this further, would you be able to submit a bug report using the form available here? Fortnite Creative

@Stevie-Moon Thanks for the info. I went ahead and submitted the bug report about 5 days ago, and have yet to hear anything back. What is the typical turn-around time for acknowledgment of a bug report?

@amedhurst Is the other person added to your team through the creator portal? Private codes are only accessible for team members.

@X_TyFighter_X Thanks for the tip. I went ahead and added two members that could help me with playtesting. Sadly, I was met with more adversity when they attempted to join the team through the shareable link that I sent them. Upon clicking it, they received a message stating: You do not have permission to join this team.

Thinking that the members needed to be enrolled into Creative Portal before it would work, they were informed that before the enrollment process could take place, they had to complete a battery of requirements, such as having an Epic account that was over 30 days old AND contributing within creative/UEFN within 7 days of the past 30. Why? These people I’m asking to playtest my map are graciously doing so pro-bono in their free time. They aren’t diehard creatives.

Epic, I really want to use this awesome tool you created. Truly, I do. But the inability for people to ad-hoc jump in and out of playtesting, which appeared to be promised to us out-of-the-box, is a non-starter. How do I know that if I decide to just skip this part and publish directly to public that people will even be able to use the map? Will it be possible, or will they be greeted with a set of errors as well?

Please, give me some surefire guidance. I have yet to hear back from the bug ticket that I submitted.


Hmm, ive added people for playtesting and all they had to do was follow the link and prove they were 18

Okay. After some more hostage negotiating with the enrollment process, I was able to get to the age verification portion, and was able to verify the age of my playtesters. It finally works! They are able to spin up and start my island via the private island code!

Thanks for the help @X_TyFighter_X

1 Like

July 2024 I still have this issue. My playtesters get the Matchmaking Error #2 cannot join at this time.