Major FPS drop in 4.18 = bug?


I have a major fps drop in 4.18 and also 4.17, but with the same map in 4.16 i have almost the double fps. If you look at the screenshots you can see that i’ve used a heavy map for testing purpose with alot of photoscanned assets and materials, but it affects other projects aswell. (Note that i’m testing one engine version at a time).

As you see in 4.16.2 i have 92 fps, but in both 4.17.2 and 4.18.1 i only have 53 fps.

From what i can see, this seems to be a much more bigger drop than whats considered “normal” when updating, right?

Is there something i can do or is it an engine bug?

If it’s a bug, please reproduce the steps i’ve done and prioritize this one, as i think it may affect alot of projects out there.

Computer specs:

Ryzen 7 1800x, Crosshair VI Hero, Nvidia GTX 1080TI, 32GB RAM, 500gb SSD, 3TB HDD, Kraken X62 Cooler.

What i’ve already tested:

Update windows, drivers, bios, chipset, clear cmos, scan whole computer, cleaned with cclean, and almost anything else regarding my computer. Check/uncheck box for the new blueprint thread function, for “use less cpu in background” and compared with different projects, unplugged my second monitor.

What to reproduce:

Create a project in 4.16 with some high cost assets to easily see the difference, do the same in 4.17 and 4.18. Open each one up, one at a time and take a note on the fps. Compare the fps amount in 4.16 to 4.17 and 4.18.
Check if it has anything to do with either Ryzen or Nvidia Gtx drivers, updates to Unreal compatibility.

Glad to hear your respone.

Thanks in advance!

Hi ,

What is the current Nvidia driver that you are using?
Also, check to see if the Nvidia Shareplay software is running as that has caused FPS issues for others recently.


Hi Jeff,

Thanks for responding. I’m currently using nvidia driver version: 388.43. I have a new update pending to be installed if i want to, but to be honest i don’t know if i should at the moment, couse of the compatibility of Unreal Engine and Nvidia drivers.

The shareplay software did i notice had been turned on for som reason, so i turned it off and it helped with the drop in blueprint editor issue, but the difference in engine versions is still the same so that did not help at all i’m afraid…

The exact same amount of drop is in both engine versions and it’s unfortunately not connected to the “nvidia shareplay”.


Currently the approved driver for the engine is 388.00 so you can try rolling back to that one and see if it makes a difference for you.

Regarding Shareplay, whenever a new driver is installed it seems to re-enable itself so it is always good to check that.

Just wanted to contribute on this subject. I’m also having incredibly bad performance on 388.43 and UE 4.16.3. It literally went from 60+fps in editor on cinematic settings to 10-15fps. I’ll try to roll back as well, hope that fixes the issues because the editor is unusable right now.

Hi Jeff.Rogers. Thanks for the tip. Disabling the NVIDIA in-game overlay feature seems to have fixed the issue. Regards, Brett

Thank you Jeff! Disabling the in-game overlay also fixed the issue I was having. I passed the tip on and it fixed the issue for another colleague as well.

Marking this as the answer as this seems to be fixing it for a lot of people. If anyone else is having issues and this does not fix it feel free to reopen the issue.

Hey brunogruber,

Please also check the Nvidia overlay software. If it is enabled try turning it off as it has been known to cause FPS drops in the editor. Screenshot attached for clarity.

Hi again Jeff.

I’m glad to hear that the in-game overlay helped som many people!

It actually helped me too as stated above, but only with the blueprint & material editor drop.

I also tried to rollback my nvidia drivers as you said, but unfortunately that still wasn’t the issue…

Just to be clear, this drop happens only in 4.17 and 4.18. The 4.16 version is still fine, so i’m guessing it’s something regarding just these engine versions, as 4.16 is stable as usual for me.

Do you have anymore suggestions for me to try out, or may it actually be an engine bug?

Please let me know.

Thank you for taking time on this matter, Jeff!

Best Regards

Hey ,

Quick question for you, are you having the FPS drops in all projects?
Or are you only experiencing the FPS drops in this one project using the same high cost assets that you have upgraded from 4.16 to 4.17-4.18

I would ask you to create a new project just to see how your FPS is and if you are still having problems we can investigate further. Thank you.

For me it was the geforce experience in game overlay. Completely fixed my issue! Thanks so much for this.

Wow, this seems to fix the issue for me too. On 4.16 even an empty map was sometimes giving me under 10fps, I even completely wiped my graphics drivers to fix it a while ago but it came back and I never connected it to the nvidia overlay (now I’m thinking the driver wipe just worked because it ended up disabling the overlay). It almost seems like the main editor window isn’t receiving proper focus and is behaving like it’s in the background since whenever I see the low fps and check cpu/gpu usage both are super low (but disabling that in the options didn’t seem to help either)

Hi again Jeff,

I have done some testing, along with some newcoming updates for my system so on and so forth.

Eventually it worked out, i am not quite sure how though… but it’s still a good thing of course!

It probably were something with the new updates, the first project is still the same drop but probably related to the item itself.
The other heavy projects i tested with before now suddenly works, with no drop between the versions.

So conclusion: In-Game Overlay (as stated above) and newer updates from my end.

I’ll be accepting your first anwser as solved to this thread and am thanking you very much for taking time solving this!

Have a great day!

Best Regards


Hi everyone,
Yet I’m still having low FPS even in default FPS example map project :frowning:
By now have tried:

  • updated video drivers + run dxdiag (directX is updated with Win10);
  • checked for in-game overlay (is not supported for my video card);
  • unchecked Smooth Frame rate;
  • run stat memory (texture memory used 141 MB of 1000 MB Streaming texture pool);
  • stat unit shows me Game: 8ms, Draw: 36ms, GPU: 36.5ms;
  • checked Physics-Framerate-Substepping;
  • scene rendering gives me 47 mesh draw calls, 26 static list draw calls;
  • tried UE versions 4.10; 4.16-4.18 - same result.

GPU Visualizer shows me 42ms for Scene (only Postprocessing takes 16ms). After uncheking everything in Rendering-Postprocessing/Default settings, Scene took only 22.5ms and FPS grew to ~38-39.

Configuration i5-6600, 16GB RAM, GT 730 2GB, Win10.
I do see that problem lies in video card (GPU: 36.5ms), but do not understand why.
Are there any possible ways to find solution?

Hi Serega, in your case it looks to be that your GPU is a bottleneck for the engine. The recommended GPU to run the editor is a GTX 470 or better. While your specs will work with the editor you will not receive desired performance levels. Click here for more information.

Thanks, Jeff,
Pity to here that. I hoped there were some additional methods to increase FPS.

V4.18.2, Disabling ingame-overlay or removing geforce experience did not higher my framerate (10-15 FPS), I guess I should be looking for something else :confused: (I did not run in 4.16)

Hello, could you post your full dxdiag so I can get an idea of what you are working with. If you are not sure how to get this information check out the steps below.

Some more information would also be helpful. What are you doing in editor when the FPS drops? Is it as soon as you open a project? When you hover over something? Any extra information would help.
Lastly, is this happening to you in a specific project or will it happen in a brand new project as well?

dxdiag steps:

  1. Using the windows search bar search for “dxdiag”

  2. From the System Tab click the “Save All Information” button.

  3. Save the text file somewhere and then upload it here.

Hello!Please Help me? Thansk!!!

This problem still persists

  • no nvidia experience software
  • the latest drivers
  • gsync turned off
  • newest UE engine
    The error still occurs in 4.26 and 4.25 for sure.