Major Bug - Unreal Engine 5 Preview 2 Morph Target Severe Flickering

I have been working on a project with preview 1 without any issues. As soon as I updated to preview 2 the morph targets on my characters meshes were flickering severely. This is both in the skeletal mesh preview and played in the level. I have tried adjusting every setting/re-importing with no fixes.

I re-imported the same skeletal mesh in a Early Access of UE5 and the flickering was not there. I currently cannot make progress on my game as I cant open it in an older version without over 50% of assets disappearing.

I have seen some reports on morph target flickering in the forums but with no feedback or solutions from anyone at all. Regardless if this bug is ignored which is most likely going to be the case, posting this here for anyone else having the same issue to see if a fix can be figured out.

One thing I have tried where the flickering stops is when I set from lit to unlit, so im guessing it’s a lighting/shader issue with the engine

Question: Is there any possible way to fix the morph target flickering?


I have the same problem exactly in UE5 Preview 2 but in ue4 everything is fine with my project , Also another weird bug with morph targets in ue5 is after packaging which makes double mesh when you morph them

1 Like

I have the exact same issue. worked in ue4, flickers in ue5. Please help!!

I have the same issue. I made a bug submission a week ago, and did not get any message after the initial automated response. I don’t know if it means they know about this bug, or what.

“In the event the issue you reported is scheduled for a future release or has known workarounds, you may not receive a follow-up message from our team”

I did not get any follow-up message, so…

1 Like

I have the same issue, if i set a morph target to my characters face its flickering. Makes no difference if i clear previous morph targets.

1 Like

I was running into the same problem and messed around a lot to try to find a solution or at least temporary workaround.

It seems like changing the anti-aliasing method from Temporal Super Resolution to any other AA method fixed the morph flickering (of course, at the cost of different anti-aliasing).

Maybe someone with more knowledge of how AA works can utilize this to find a real solution.


Same here.

  1. Try to disable motion blur in project settings - rendering.
  2. Anti-Aliasing Method tests:
    Temporal Super-Resolution (TSR) - flickering
    MSAA (8x MSAA) - no flickering
    TAA - Flickering
    FXAA - no flickering
    NO - no flickering

I just got a message that it is a known issue now. You can track it here:


Thanks for sharing this

Thanks for the reporting guys. It’s been over three months and the bug has still not been fixed or even acknowledged by the UE5 devs. Disappointing and ridiculous as it prevents morph targets from being used at all. I’m just going to use UE4 for my next projects in the indefinite future or find another 3D game engine, it doesn’t seem like this issue is going to be fixed any time soon.

FYI for anyone who desperately wants to set morph targets with AA without flicker.

  • Using timeline to set morph removes flickering for me… yeah i know its not clean but hope it’s helpful.
  • make sure the timeline doesnt go straight to max on your timeline. e.g. if max morph = 1 then have it go from 0-1 even if its really quick

1 Like

Aw this must be the same cause to the issue I just posted about here: Morph Target Shimmer/Flickering

One thing i did that helped was turn off motion blur by bone. But for me it comes back if i pick up the morphed mesh

Oh my god, you’re such a lifesaver. It makes sense a timeline works, because I think the problem is how the motion blur is calculated, if the mesh vertices change position gradually over time then the motion blur will be almost zero.
If you change the value from lets say 0 to 1 in a regular function call the vertices change position in a single frame, that causes massive motion blur to occur and it somehow gets locked in the blurred state.

I wanted to change the value instantly to 1, I found that adding 3 keys in a timeline of .25 seconds works perfectly first key is at value 1 second key at value 0.99 in the middle and the last key again at 1. This makes the change from 0 to 1 instant and causes zero flickering.

1 Like

It’s a ■■■■■■■ game changer mate lol. Glad it helped

What solved the problem for me was disabling Moting Blur and enabling Support Compute Skin Cache


I still have a flickering problem after setting morph targets in 5.2. One way I got it to stop is by setting the mesh visibility off, then set the morph targets, and then turn mesh visibility back on afterwards. Dunno if this same issue but this works for me.

I tried with and without Motion blur, it seems to be the exact same, the “Support Compute Skin Cache” seems to completely fix it.

Will also attempt the timeline, just to check. But thanks for this Raskolnikow!

1 Like

Yes! Experiencing a very similar issue! My Morph Target Mesh is able to be viewed when in path tracer render but not in any other view

character got eyes flickering like crazy in 5.2, worked fine in 5.1

This is my solution for my situation, I have a character customization system that changes face and body shapes, as usual the flickering is intense and disgusting.

What I noticed about the flickering is that only the vertexes affected in the most recently modified morph targets flicker. So to solve it I made a morph target that has virtually no changes (just a single vertex that moves a fraction of a unit) I named it fix_flickering and made a blueprint that sets it to a random value between 0.2 - 1.0, so everytime I change the value on other morph targets there’s a 0.1 second delay and then the fix_flickering morph target is set to a new value and that gets rid of the flickering on the previously affected areas.

Note that this work around does not work if
1: The delay is less than 0.1
2: The value in the the morph target that fixes the flickering is used twice in a roll (this is why I have made it a random float).

I doubt if this will work well for talking animations but if you are simply trying to change a character facial or body appearance its good enough.