Main menu on shooter demo not visible


I am using 4.5 on a mac, downloaded shooter demo and opened the “ShooterEntry” map. and menu is not visible, I downloaded this project on older versions of editor and I remember there used to be a menu where player could select play, join, host game, etc.

Why is this no longer working ?

This is what I see when I run the “ShooterEntry” map:

Hey Titirez5,

If you package game and play resulting .exe, menu will show up. That menu doesn’t show up when Launching through Editor. I checked in 4.3 and 4.4 as well as 4.5, and it seems that’s always been case. Were you seeing something different in earlier versions? If so, what method were you using to play game?

IIRC you couldn’t see a menu there in older versions, I think I tried once.

When you open ShooterGame solution with Visual Studio there’s actually a “ShooterMainMenu.cpp”
and “ShooterMainMenu.h”.

I think they did menu in C++.

To create a Visual Studio file of ShooterGame Example, navigate to your UnrealProjects folder, right click uproject file and click “Generate Visual Studio project files”.
Then open ShooterGame.sln.

You might be right, maybe it was a build I saw this in, and not editor, it was a while ago…
This makes it even more difficult to follow multiplayer logic from this demo. While running project from IDE you could at least add some logs and put some breakpoints.

Titirez5, in Xcode, go to project selection drop down and open it. Select ShooterGameEditor. Then re-open same drop down and go all way to bottom and select Edit Scheme… Then select Run > Arguments & add an extra argument to list: -game
Then build & run. editor will run from Xcode in ‘game’ mode and allow you to debug menu flow.

Does anyone know what steps need to be taken in order to fix this to work in editor?

Hi Heoki,

steps listed above should let you debug menu flow. Have you tried that yet?

I’m not sure, I am using visual studio so those exact steps wont work but I can load up game to test menu flow but it would be more convenient if I could do it by just loading up level in editor.

Hey Heoki,

Being a C++ project, ShooterGame is going to have some things that are not conveniently tested in editor. When debugging through VisualStudio or Xcode, you’ll be able to test menu flow.

I also have this problem on v4.7.5. Why does EpicGames still not fix this bug? This is strange.

I agree, I’m having same problem of not being able to see menu. I just want to follow logic for how gamemode, gamestate, and hosting/joining work, as well as some menu features. It’s a shame you need to track down tutorials to get tutorials to work