Macro UV issue in Niagara

I’m attempting to use Macro UVs in a Niagara emitter, but I’m consistently running into the same issue. The material I’m using is stretched, upside down, offset, and seemingly displayed in screen space. I’m easily able to fix most of the issues by manipulating the UVs in the material, but I haven’t found a suitable fix for making the image display in world space.

I imagine this must either be a bug or perhaps that Macro UVs in Niagara aren’t quite ready for use? I can’t find any modules or settings in Niagara that allow you to manipulate Macro UVs through the emitter (unless I’m missing something). Using the exact same material in a Cascade emitter results in the image being displayed as expected. I’ve included a gif below of a Cascade emitter (left) and a Niagara emitter (right) both displaying the same material to wildly different results.

Any suggestions for a way to get the Niagara Macro UVs displaying like the Cascade ones?

I am having same issue, have you found any solution for this ?