Macro Library: Can't reparent Macro Library with "Object" class

If you make a macro library using Actor as Parent Class, and then try to change Parent Class to Object in Class Settings, search field only finds



Hi JoystickMonkey,

Thanks for report! I was able to reproduce this in 4.8.1 and our internal build, and I’ve created a bug report for it (UE-18552). I’ll let you know when I see any update on it. Thanks!

still not working in 4.9.0, just a reminder

Still not working in 4.12.5, just a reminder.

This issue is still being investigated by our developers; however, there is currently no timeline for when a fix will be released.

Have a great day

Same problem with regular actors. You can’t re-parent an actor to a parent class, only child classes.
Would love to get this functionality

4.19, any news if this functionality is still beeing worked on?


This issue has not been resolved at this time; however, you can use link below to track any future progress on this:



4 Years later, still not resolved

Man, it’s gonna be at least a full day’s work for me to rebuild my macro library from scratch parented to Object :frowning:

1 Like

Years later, it’s still not resolved. Is there any way you could pass this on to team? It’s such a small bug but it requires so much time and unnecessary busywork to get around. Thank you.

how is this still persistent?