MacBook Pro heating. Unreal 4.6.1

MacBook Pro Retina (July 12)
Processor: 2.6 GHz Intel Core i7
Memory: 8 GB 1600 MHz DDR3
Graphics: NVIDIA GeForce GT 650M 1024 MB
Mac OS X 10.9.5
Second monitor.

Unreal Engine 4.6.1

MacBook becomes very hot very fast in several minutes after launching of Unreal Editor. Cooling system becomes very crazy and noisy. I think you should pay more attention to optimization for Mac. Sorry if I offended you. It was not my goal.

I do not experience the same problem on PC with integrated Intel 4600 with the same almost empty scenes.

Hey Michael,

This is normal behavior for the Editor on the MacBooks. The only thing you can do to prevent this is to disable Realtime in the Viewports and set maxfps to ~30 to 40. The developers continue to make improvements for the Mac, but that may not be something that can be fixed much. You may also find improved performance using Yosemite (10.10.1), but I don’t know if that will help with this particular behavior.

Unity Engine is more delicate with my MacBook :))

OK. Thanks :slight_smile:

Hm, I often worked outdoors and with the Unity Editor and cpu/gpu usage never was an issue. Now I am planning to start with Unreal, but that noise really drives me cracy and battery is dying very fast . At least, during “Stop”, there should be an option, to shut rendering off. I don´t need all that animations going on, when scripting.

Will there be a solution?

how do you disable realtime in the viewports and set maxfps to 30 to 40? Much thanks for the answer