Mac OS 10.9.2 Mavericks. Launch Editor U4?

Nevertheless Unreal engine is great, and the blueprint concept, following in kismet´s footsteps, is a fantastic idea. Now lets see if you guys at Epic get beyond the MS game-nerds-buy-me-faster-graphics-fandom-world. The engine would deserve it, no question. We here at SYA and KTX have been developing and published “Haunted:Hells Reach” with Unreal for THQ, so I know what I am talking about, ups and downsides.
Best regards
Michael H. Musal
Creative Director

It sounds like there are a couple of different issues.

While Michael Trepka and others are figuring out and fixing the bugs causing the Mac version to crash that are unrelated to the min system requirement, let me please extend my apologies for our minimum system requirements on the GPU side not being clearer upfront.

Please contact us if your GPU is below the min spec as identified by Michael above and we will issue you a refund and will hook you up once our requirements are compatible with your Mac/PC.

Thanks for being an early adopter!

I am having the same issue. I have a yiynova monitor (http://www.amazon.com/Yiynova-MSP19U-Monitor-Windows-Solution/dp/B009QQ7BG0), similar to a Cinitiq. If I unplug the usb connection to the monitor, it works fine, but then I can’t track stylus input on the monitor. Unity 4 has always worked fine with this monitor. I have attached the crash logs as requested.link text

I noticed that if I unplug the monitor, launch the editor and level, then plug in the monitor, it works fine. Tedious to do this for each project though. So somewhere in the launch it is crashing (recognizing the monitor as a joystick?)

I’m very sorry for inconvenience. I’ll look into this first thing in the morning and do my best to have a patch for you tomorrow.

That did the trick… disconnected my Wacom Tablet and the Editor fired right up. Thank you.

Same issue verified due to having a PS3 controller plugged into the machine. Thanks for the comment!

Not sure if you read the notes on the subscription page? It says that the OSX version still needs some work.
And while I had the same issue (it was my Wacom) it’s mind boggling how fast the devs here respond and obviously try their best to resolve issues.

Also I think it’s still better to have a Windows machine for serious game development anyways.

Hi, Daniel,
thx for the offer, and clearing the air, appreciate it very much. Mac Pro´s usually do not touch a running system. Systems are stable standard workflows and run for years and years ,aimed to make money with different media products. There are chances that UE will be the industry standard for game development, if you succeed in terms of seamless compatibility.

Best

Mike

Don´t think so. Media production is an Apple thing, consuming them is a WIN thing, except with games… Ask the distributors, they´ll confirm.Never mind. Result?There are 4 games out of a hundred which went into production that pay off, and 8 out of ten productions fail in completion or announced street date. Desaster, right? So lets not talk about serious game development. There is almost none.

I happen to also have Wacom Cintiq 13HD attached to my Macbook. Looks like the problem is here as was stated above.

I am having the same problem here, Unreal boots and then stops, as soon as I unplug the wacom all works fine.

As a little edition if you fire up the engine and then plug the wacom back in it works fine.

confirmed, this also solves my crashing issue.

Totally understand – once you buy a Mac Pro you expect to be able to use it at the very least till there is a new one out and available. We just barely received ours and the engine should run really well on those.

Ok, so we found out how to launch and see a reasonable viewport. Machine is still iMac with OS 10.9.2 , Processor 2,66 GHz Intel Core 2 Duo, Memory 4 GB 800 MHz DDR2 SDRAM ,Graphics ATI Radeon HD 2600 Pro 256 MB.

  1. Disconnect any USB devices: tablet, printer,pads, scanner, musical instrument interface, USB Hubs. External HD with USB works.
  2. Now open blank project.
  3. The screen shows oszillating ■■■■. Go to quicksettings and change. Especially the tonemapper option.
    Like this:

screen+shot+2014-03-20+at+15.57.05.png

  1. Scale some realtime options. Like this.

screen+shot+2014-03-20+at+15.59.15.png

Hi Michael. I have posted the workaround to launch and have realtime editor working appropriately on the machine below.

I had a problem with the editor crashing on start up, this is what showed in the logs:

[2014.03.20-15.07.56:968][ 0]LogLoad:
Full Startup: 10.90 seconds (BP
compile: 0.13 seconds)
[2014.03.20-15.07.57:434][ 0]LogMac:
=== Critical error: === SIGSEGV: invalid attempt to access memory at
address 0x

[2014.03.20-15.07.57:434][ 0]LogMac:
Fatal error!

EngineCrashHandler(FGenericCrashContext
const&) [in UE4Editor) + 15 , line
177481080] [in UE4Editor]
PlatformCrashHandler(int, __siginfo*,
void*) [in UE4Editor-Core.dylib) + 95
, line 177481080] [in
UE4Editor-Core.dylib]
_sigtramp() Address = 0x89ebe5aa (filename not found) [in
libsystem_platform.dylib]

Similar to the connected gamepad above, I unplugged my Logitech M570 trackball and things started launching just fine. Hooking the trackball back up after the editor launched seemed to work just fine.

Specs: late 2013 model MacBook Pro, 2.7GHz i7, 16G RAM, NVIDIA GeForce GT 650M.

There are three main points causing the trouble : USB input devices, tonemapper option, and no support for two or three items in the scalable realtime features.

Making some changes with the USB input devices gives way to launch a blank project, putting off the tonemapper in the post processing options, and scaling something in the realtime options does it, i think. Now we will have some tests on the weekend how to use blueprint, trying out with the blank project.