Mac OS 10.9.2 Mavericks. Launch Editor U4?

The editor, freshly installed and verified, starts to launch, shows up with the new project window for a second, and disappears again, quitting the editor . How that?

Hey Michael,

Can you tell us your machine specs? Have you tried restarting your Mac? Any further information may help us to figure out what is happening.

Best,

Ben Halliday

I have the same problem. Macbook Pro late 2013, 16Gb, i7 2.3 Ghz, GT 750M. I also tried to open content samples from My Content, but UnrealEd only pops up for a moment and then disappears.

I also have a similar problem on my iMac 27" (late 2009).

My issue is that the editor quits with a fatal error after calling FOpenGL::CheckFrameBuffer in FOpenGLDynamicRHI::GetOpenGLFramebuffer with NumSimultaneousRenderTargets = 4

I get this error message in the console

LogRenderer:Warning: Reallocating scene render targets to support 1520x1280.
/Users/lukasz/projects/UnrealEngine/Engine/Source/Runtime/OpenGLDrv/Public/OpenGL.h(277): Fatal error:
Framebuffer not complete. Status = 0x8cdd

If I comment the FOpenGL::CheckFrameBuffer call the editor runs, but the editor viewport renders garbage (see screenshot below). So I assume my graphics card does not support the render target configuration requested by the editor and quits.

Hi, Ben,
thx a lot for accepting the question and answering. Yes, the restart was done, as usual. The requirements of the hardware may be the reason, but all the bigger realtime packages like Unity4 and Maxon C4D do, so I tried… However, it´s an iMac with OS 10.9.2 , Processor 2,66 GHz Intel Core 2 Duo, Memory 4 GB 800 MHz DDR2 SDRAM, running 10.9.2. ,Graphics ATI Radeon HD 2600 Pro 256 MB.

I have the same problem… Mac Pro (2) 3.2GHz Quad-Core Intel Xeon, 10GB RAM, Nvidia GeForce 660 Ti 2GB Video Card. Running OS X 10.9.2.

Hm. Having this problem, too, I thought it was the hardware… but obviously not the installed RAM, cause I see a bigger RAM here than required.

The launcher itself shows up fine, the verification says ok, and there is no hardware alert ( kinda :you can´t run this here) or something like that.

Ouch. This one exceeds any required specs.Hmm…

I’m afraid that Radeon HD 2600 does not meet system requirements:

SYSTEM REQUIREMENTS:
Desktop PC or Mac
Windows 7 64-bit or Mac OS X 10.9.2 or later
Quad-core Intel or AMD processor, 2.5 GHz or faster
NVIDIA GeForce 470 GTX or AMD Radeon 6870 HD series card or higher
8 GB RAM

Any card that does not support OpenGL 4.1 won’t work with UE4 editor. Sorry.

Your graphics card does not support rendering to volume textures, which we use for some effects. I believe you can switch viewport to Unlit mode and play with the editor this way, but that’s not enough for any serious work.

First of all, please try using verify/repair option in Unreal Engine Launcher.

If that doesn’t help, please look for engine log files in ~/Library/Application Support/Epic/Engine/Saved/Logs and UE4Editor crash reports in ~/Library/Logs/DiagnosticReports. When you find them, please zip them and attach here. Thanks!

MacBook Pro late 2013, 16Gb, i7 2.3 Ghz, GT 750M is one of the models we tested a lot and used for development, so I know that in general UE4 editor works on it (I even ran it OK on integrated Intel Iris Pro card).

Like I suggested below, could you try verify/repair option in the Unreal Engine Launcher and if that doesn’t help, send me UE4 logs from ~/Library/Application Support/Epic/Engine/Saved/Logs and ~/Library/Logs/DiagnosticReports? Thanks!

Apparently the crash is somewhere in our gamepad/joystick code :frowning: Do you have any gamepad connected? Could you try without it? Or maybe some other USB device is fooling our USB code to think it’s a gamepad and accessing it results in a crash.

No luck after verifying install. I noticed after each unsuccessful launch, my ram is sucked up and doesn’t release. link text

My logs are attached. thanks.

Yes, compatibility remains a problem. Maya and Maxon C4D are using Open GL as well, got no problems, and there are other environments which run fine and will do for development. I´d recommend to implement a more flexible realtime set, which detects graphics and allows for different Open GL configs.That´ll settle all the problems with graphic cards for users.

I also have the same problem, editor shows briefly and then crashes - OSX 10.9.2 - Mac Pro 2013 .

Well… so people should buy different hardware for serious work with UE4, is that what you suggest? How about supporting a wider range of hardware and getting really platform independent?

This seems to line up with my editor issue issue. If i connect my Wacom Intuos5 tablet to the computer, the editor crashes in this manner, although it doesn’t do the same on Windows. Will there be support for tablets?

I have a Wacom Tablet. I’ll try unplugging later when I get back to my desk. Thanks