Download

M1 Mac 4.26 Compatibility Report

I wouldn’t use an M1 mac for any unreal dev at all, even a ■■■■ windows machine with intel graphics would be better. I would only ever use an m1 mac for remote compiling from a main windows dev machine. Fingers crossed that 4.27 fixes the editor on arm macs.

3 Likes

So i got my hands on an M1, same problems at first.

But i got it to work stable now (1-2 weeks without crashes) by cooking content for Mac and allowing the editor to use the cooked content.

Project Settings:

  • Project > Supported Platforms > Enable Mac
  • Platforms > Mac > Enable Force 32bit Floating Point Precision (not sure if necessary)
  • Platforms > Mac > Architectures to Package For (Experimental) > choose Apple Silicon
  • Engine > Cooker > Enable Allow Cooked Content In The Editor
    now in the editor let it cook for Mac
  • File > Cook content for Mac
    and let it cook.

(Also i’m running File > Validate Data to let it pre-compile a lot before starting work with the editor.)

Other factors like render settings or project size (my machine here has only 8GB) don’t seem to make a difference with stability.
A bigger desktop example project from the launcher (infiltrator demo) might run nicely for a long time but a small basic ThirdPersonTemplate can crash right after opening it.

Editor FPS performance humiliates a 3500€/$ MacbookPro (16fps vs 120fps in ActionRPG Example).
But, like others already stated, compile times are slower so coders would benefit from an intel-cpu for better compile times.

6 Likes

Still no issues? I’m weary of reinstalling as it bricked my Mac last time and I’m out of warranty.

Just trying to write some blueprint code without killing my back at my desk or being stuck inside :stuck_out_tongue:

No issues here, tried several projects of different sizes.
I hope it’s not just me :joy:
But no one can give a guarantee. If you worry about a bricked system, don’t force reset with the power-button if MacOS freezes. Leave it and check later. It will eventually continue, like nothing happened. It just takes an annoying long long time… (half an hour maybe?)

Another small tip some might find useful in certain situations:
When dealing with a heavy scene or not-yet-optimized content on a Retina/4K/5K monitor, uncheck “Enable High DPI Support” in Editor Preferences.
The Editor-UI will look like HD (only the UI, viewport/game still sharp), but that’s an okay trade-off for another very noticeable FPS boost for the UE4-Editor.

1 Like

Are you still having the freezing issue after adjusting your settings?

I tried letting it sit but it seems I wasn’t patient enough… lol

Never any freezing and no graphic glitches with settings above.
I am using 4.26 for almost 2 months like this. Very smooth on 5K monitor, especially with editor setting “Enable High DPI Support” off.

Just remember to “Cook content for Mac” and “Validate Data” whenever you change platform settings for MacOS in the project settings.

In project settings > Cooker , i enabled the first two options to let is also cook in the background, to speed things up, when needed.

Good luck!

2 Likes

Got it working over this way!

Thanks again for your help :slight_smile:

1 Like

It’s working really well for me, but I can’t wait for native Apple silicon version. Anyone had any luck building the arm version from source?