Lyra Starter Game, UE 5.0.1, VS 2019, Immediate compile errors

I have the latest version of UE 5.0.1 installed.
I’ve even made sure it’s updated. I’ve successfully created “blank” template starter games, added C++ to them, and it works fine.

I have the latest version of the Lyra starter game template downloaded.
I even deleted and re-downloaded this.

I have the latest version of Visual Studio 2019 installed, with C++ tool chain (this has worked fine for other projects at other times, too.)

I create a new project from the Lyra Starter Project in EPIC launcher, and place it in D:\UEProjects\LyraStarterGame
I open the project.
I press the “compile” button in the bottom-right compile menu.

I get an error message that hot reload failed, because of an unexpected build tool, with a path to my rc.exe executable.

UE builds have always been struck me as less well supported than the main art path, especially compared to products where “clean builds on a variety of targets” is the main deliverable goal. An embedded Linux make menuconfig is quite straightforward, by comparison, for example.

But, like, … why does this simple flow fail? With all the marketing push behind the Lyra starter game, well produced tutorials, developer support all behind it, how can this basic “press the button on the most standard workflow” flow be broken?
Today, I didn’t want to debug build problems. Today, I wanted to just put some pixels on the screen. But, no. That’s not for today.

1 Like

ERROR: Unable to patch action graph - unexpected executable in compile action (C:\Program Files (x86)\Windows Kits\10\bin\10.0.18362.0\x64\rc.exe)


  • Create new Lyra project.
  • Open project.
  • Click “update” when it says project file is out of date.
  • Click compile/build button.
  • Get this error.
1 Like

Hi jwatte,

I’m sure I read that it only compiles with VS2020, but I haven’t been able to find any reference to it.

1 Like

Yeah, I was looking for that too, and the latest available says 2019 (which is why I use it.)

The file in the github source also says, very explicitly:  Install **Visual Studio 2019**.

I really don’t want to upgrade, only to find it still doesn’t work, and then downgrading is … very hard.

Also, turning off live coding, and building, eventually ends up with this error:

CompilerResultsLog:    Creating library D:\UEProjects\LyraStarterGame\Intermediate\Build\Win64\UnrealEditor\Development\LyraGame\UnrealEditor-LyraGame-5925.lib and object D:\UEProjects\LyraStarterGame\Intermediate\Build\Win64\UnrealEditor\Development\LyraGame\UnrealEditor-LyraGame-5925.exp
CompilerResultsLog: [114/118] Link UnrealEditor-ShooterCoreRuntime-0001.dll
CompilerResultsLog: Error: LINK : fatal error LNK1181: cannot open input file 'D:\UEProjects\LyraStarterGame\Intermediate\Build\Win64\UnrealEditor\Development\LyraGame\UnrealEditor-LyraGame.lib'
CompilerResultsLog: [115/118] Link UnrealEditor-TopDownArenaRuntime-0001.dll
CompilerResultsLog: Error: LINK : fatal error LNK1181: cannot open input file 'D:\UEProjects\LyraStarterGame\Intermediate\Build\Win64\UnrealEditor\Development\LyraGame\UnrealEditor-LyraGame.lib'
CompilerResultsLog: [116/118] Link UnrealEditor-LyraEditor-0536.dll
CompilerResultsLog:    Creating library D:\UEProjects\LyraStarterGame\Intermediate\Build\Win64\UnrealEditor\Development\LyraEditor\UnrealEditor-LyraEditor-0536.suppressed.lib and object D:\UEProjects\LyraStarterGame\Intermediate\Build\Win64\UnrealEditor\Development\LyraEditor\UnrealEditor-LyraEditor-0536.suppressed.exp
CompilerResultsLog: [117/118] Link UnrealEditor-LyraGame-5925.dll
CompilerResultsLog: Error: LINK : fatal error LNK1181: cannot open input file 'D:\UEProjects\LyraStarterGame\Plugins\GameSettings\Intermediate\Build\Win64\UnrealEditor\Development\GameSettings\UnrealEditor-GameSettings.lib'
LogMainFrame: MainFrame: Module compiling took 205.393 seconds
Warning: HotReload failed, recompile failed
1 Like

Is that in a Lyra github base? I hadn’t realized they’d released one yet.

I had to reinstall windows, so only installed vs2020 (made it an easy decision) but I can confirm that I get the same live code errors, but compiling in 2020 from the project downloaded from the marketplace without it running does build ok on my system.


No, this is the regular EPIC games launcher project.
When I say “the github readme” I mean the github for 5.0 main branch.

Also, by “2020” I assume you mean 2022?

I see what you mean, yeah I’ve compiled UE5 on both VS2019 and 2022 (yes 2022) with no problems. I just didn’t try building lyra on VS2019 as I had read that note about it only working on 2022.

1 Like

Following up on this, after trying a few different configuration (and sending a few crash reports — again, plain tools, no local changes) I’ve gotten live coding in Lyra to work.

  • Yes, I had to install Visual Studio 2022. I had to open it up and make sure a dummy hello world C++ project could be made/built.
  • Then I selected Visual Studio 2022 in the project settings (it defaults to auto-switcher Visual Studio, which might still choose 2019)
  • Then I did a Build Project (without live coding) in the UE5 editor, which completed.
  • Then I quit the UE5 editor.
  • Then I had to right-click the .uproject in the Content folder, and select “generate visual studio project,” because the projects weren’t generated
    already. (“Build project” apparently goes straight to each vcxproj, rather than calling msbuild at top-level.)
  • Then I had to open up the sln and ctrl-B it in Visual Studio.
  • Then I opened the UE5 editor again, and enabled live coding, and pressing the compile/reload button worked.

One or two of these steps may not be necessary, but at least, if someone else runs into this problem, and finds this thread, they should be able to repeat these steps. Thanks for the help!