Luoshuang's GPULightmass

Any get a 2080ti and been using GPU Lightmass? Hows it comparing to the 1000 series?

Unless you’re asking people who got one as a reviewer, or outside of street date, nobody has one. The release got pushed back by a week, to the 27th.
Though I suppose some people might have gotten their hands on them, since they’re probably just chilling out at stores, and some stores might not care about street dates when it comes to hardware.


Would it be possible to add command line argument, so that source build could be run with GPULightmass when using cmd line argument or with stock Lightmass, when not using said argument?

Just a question. There is a way to activate/deactivate the script? i’m working on diferent projects and don’t wanna use Gpu on all of them.

Not that I know of. That’s why I asked if it’s possible to add cmd line argument for easy switch between stock Lightmass and GPULightmass :slight_smile:

Read this post:

I really do not want to use any 3rd party apps. I think cmd line argument is the way to go.

What a surprise at finish of the bake: an error - GPU lightmass crashed … but As I see all results of baking have been applied to the scene.
Baked with Extreme+Production setup.
( GPU RAM of my GTX1080 was 100% full during the bake process )

hi @Luoshuang
thanks for last version 4.20.2 Unified Settings ]
its working correctly without sharp shadows
i enjoy the quality of last version


the only problem is vram and gpu memory
how gpu renderers like octane and redshft solved this problem ?
why we cant share ram or pagefile with gpu lightmass ???

[FONT=trebuchet ms]Hello, @Farshid

Don’t you mind telling, where did you got the GPU Lightmass binaries for 4.20.2 please ?
I’m interested to use it for my project who can’t run on 4.19 anymore due to some C++ API changes.

Thank you guys !
And thank you @Luoshuang for sharing this tool with us!

when will it be aveable for 4.20.3??

It already is, the .bat installer too.

Same question guys. I accidentally hit the update button and there is no way to turn back :frowning:

Same answer as above.

4.20.2 and 4.20.3 share the same core, so it’s the same binary. You can use the bat installer and it’ll do it for you.

this looks really nice and clean. if you don’t mind what is your lightmass settings ?

You may want to read the first post, lightmass settings other than bounces are ignored by GPU.

This is a downloadable demo scene from the “multi-bounced skylight” thread if you want to try it yourself.

One thing I’m curious about, the gist I’m getting is that Swarm works just fine with this, but is the scene split up in any way, or will the scene take up equally much vram on any gpu used?
Like if I’ve got a scene that takes up 9GB vram, and I can lightmap it just fine on my desktop, would it work in swarm if I also pushed it to a secondary desktop with ~8GB?

After all, the entire scene has to be loaded on each pc, but since there’s less work to do ( fewer texels to lightmap, etc, per gpu.) I wonder if the vram usage per pc goes down a bit or not.

edit: I ran a couple tests, and it looks like Vram usage is completely unaffected. Though atleast the servant-pcs use less vram, much like when ordering a lightmap from commandline / without opening the editor.

Hi Luoshuang I have to report that in condition of little light even in extreme quality appear these splotches. There is a way to solve them or I have to return to CPU? It’s truly a pity because I’m in love with GPU lightmass speed and it’s indirect shadows

Hi. First of all - Lighmass GPU is a miracle. And there is no way back to CPU. It’s superfast and clean. I’m doing some personal archviz project - just a small house in a natural environment. I almost finished the house and it looks great (and takes about 5 min on Extreme with my 1080). I started to build environment and i’ve got some lightmap artifacts on the foliage and other objects. UVs are fine and test CPU bake looks exactly as it should be. Any thoughts?

Interior test (it shows superiority GPU over CPU - on CPU it would take hours to that quality bake):

It’s most likely because your LODs are poking out. From the OP: