Download

Luoshuang's GPULightmass

Which problem will be fixed with new files?

May I ask you to see my post #524, I rebuild the geometry, but the problem is still there.

Thanks!

Kind of hard to see on your screenshots, as every shot has a different angle. But seems to me you have rotated UVs, even if red, the artifacts seems to be related to UV resolution, and more importantly texels not been aligned to the edges. You can even see some blue lines in the same locations. The fact is that GPU lightmass is much more sensitive to this issues than CPU. I believe this was discussed in this thread before.

@Luoshuang

Well, that source you shared a few posts ago doesn’t seem to work with binaries for 4.20.2. UE 4.20.3 builds fine with it, but then if I use .dlls and .exe from binary package for 4.20.2, Lightmass (swarm rather) fails. If I only use GPULightmass DLL from binary package, I get this crash: <None> === Lightmass crashed: ===Assertion failed: (Index >= 0) & (Index < Arr - Pastebin.com

I probably need 4.20.3 binary package from you in order to make it work with the new source you released a few posts above.

The idea is to build only UnrealEd (do not build UnrealLightmass) and use all the binaries excluding UE4Editor-UnrealEd.dll

I can’t not build Lightmass. It builds with UnrealEd by default.

I tried again.

I built UE 4.20.3 from source, then I did the code changes according to your source files and copied GPULightmassKernel.dll into where it should be (along with reporter app and .ini changes). Then I re-built UnrealEd, copied the rest of the files from 4.20.2 binary package you provided (except for UE4Editor-UnrealEd.dll), overwrote existing files.

Now it seems that lighting is being built, but I don’t see reporter window pop-up. Scene is extremely simple, so maybe that’s why?

EDIT: Built lighting on a complex scene - same thing - progress bar for GPULIghtmap doesn’t show up in the top left corner of the screen as it used to with 4.19.x engine.

Did you forget to place ProgressReporter.exe in the proper folder?

Just want to say everything works like a charm now on my 1080Ti with a source build. Even rendering with crazy high DevOptions!
One thing I haven’t seen mentioned in the thread is that the “Use emissive for static lighting” checkbox now works. On previous version emissivenes was always taken into account.

I sure did, but now I went over the code changes and I put path to the reporter into 32bit dependencies block of code :stuck_out_tongue: Fixed it and rebuilding… Fingers crossed :slight_smile:

Is Working for 4.20.3?

So, finally got it running (at least reporter shows up and building times are definitely faster than on CPU). However, this is what I am getting:

https://youtube.com/watch?v=XoYH80F8egA](https://www.youtube.com/watch?v=XoYH80F8egA)

Not really sure what’s going on. It looks like lighting works as expected, when showing level in Lighting only mode. However as soon as textures are back on, as if there is no indirect lighting :frowning:

What are your world settings like? how many light bounces?

Have you tried reloading the level? I found sometimes light maps or materials failing with black after baking

Finally and may not be related, but seems you are killing specularity on your material, which may change how light bounces of it or reflects on your reflection capture actors, not just the look.

I show the entire setup, including materials, world and lights settings in that video.

Having fully rough materials is necessary for performance reasons - the project is for mobile VR.

Maybe you can tell me the time of the video where world settings are shown. Also a good look at the base color would be good indicator. My guessing is your textures are extreamly dark for lighting information to properly bounce off. Can you show the same with CPU lightmass?

What kind of sorcery is this - I could have swore I recorded the world settings :frowning:

Here is what I got:

ue4_gpulightmass_worldsettings.PNG

To show it in CPU Lightmass, I’d have to convert project into another version of UE4 :frowning:

I don’t think this is related to GPU Lightmass. If you tried everything else, only trying CPU lightmass to make it sure is what’s left. You can repair the installation by using “verify” on the epic launcher, that would take you back to CPU. After that, you can use this scriptto save CPU lightmass files and change between CPU and GPU on-the-fly without much hassle later if you whish to get back to GPU.

While CPU Lightmass did better than GPU LIghtmass, it wasn’t really any better.

Not quite sure what’s going on. Going to mess with faking indirect lighting.

P.S. Strangely enough, it looks better in ES3.1 preview :

https://youtube.com/watch?v=iFKnIh1wsQg

imo this problem has nothing to do with GPU Lightmass. If I had to guess, I’d say your textures are way too dark.
Double check your textures, here is a guideline of how dark “black” color in PBR textures should look like:
https://docs.unity3d.com/uploads/ExpertGuides/Dark_Dielectric_Materials.pdf

Seems like I got something going:

https://youtube.com/watch?v=FAdOXwZPFjE

Does that mean that Direct Lighting from Static lights is also affected by the world settings like Static Lighting Level Scale?

Every time I start lighting built, Windows keeps asking me if I want to launch Reporter. Even if I uncheck option to ask me every time it launches, I am still being asked. Is there any way I can get a rid of that annoying pop-up dialogue?