Download

Lumen too subtle in custom/imported scene?

Hey, so in the examples I’ve seen from Epic, lumen is very clearly bouncing light off surfaces and producing some nice global illumination.

But I’m having trouble replicating this in my own scene.
I’ve gone through the documentation and set it up, but it’s hardly visible.
E.G, here’s a emissive object near a surface:

No signs of any light bouncing off.

However, if I move closer and put the surface at a more extreme angle:


You can see som light bouncing of the nearby surface, so it is indeed working, however it’s so weak and subtle it might as well not be there.

Any ideas of how I can make it more pronounced?

If it has a light, increase indirect lighting intensity on it. If it’s just an emissive texture I believe there’s a console command to boost GI coming from those but its global so will change every emissive material in your scene

I can’t see any visible effect from that setting, whether at 0 or 6 from any of my point lights or my main directional sunlight. Just that small, subtle glow and certain angles.

If it’s not working, it’s probably because there is something blocking the light. It could be what you are using for the sky?

For emissive surfaces it’s a bit tricky. You can sometimes get more glow than actual light depending on your exposure settings.

Is you exposure fixed or auto?

I’m using manual exposure set to 15 and a directional light with 6 lux brightness, the light isn’t being blocked and is working, but the bounces are very subtle.

As you can see, if I place a very brightly colored object, I get light bouncing off it:

But everything else has very plain, gray shadowing with very little color being picked up from surrounding materials.

Like @Nihito said, boost indirect lighting. You can go over the cap and type 20, 50, 100, etc.

Last resort is to make sure GI is set to Lumen. PPV not set to unbound happens to the best of us :sweat_smile:

I think the problem is the trace distance is cutting out. Try increasing the mesh distance field trace distance with the console command r.Lumen.DiffuseIndirect.MaxMeshSDFTraceDistance, which is 180.0 (~2 meters) by default. Make sure what you set it to is less than r.Lumen.MaxTraceDistance (10000.0 by default), but you can increase that, too.

Ah, I didn’t realize you could go beyond the slider max, setting to more along the lines of 50 got more of the results I was expecting!

1 Like