Download

Lumen Scene / bright interiors and broken reflections (kind of solved)

UPDATE:

So the standard setting is:
r.Lumen.MaxTraceDistance = “10000.0”

changing that value will solve the issue with the limited reflection distance.

The other problem I could kind of solve by changing the proxy triangle percent in the mesh settings. This is not a great solution since its causing a huge performance drop with highpoly meshes.


Original post:

So. I was wondering why my interior is looking very bright and flat. After checking everything I could think of I found out that the Lumen Scene view is looking very broken. Is there any console command I could try or do I have to do something different with my meshes?

light only


lit

lumen scene

nanite overview

distancefield

global df

It looks like from your nanite view that this corridor is made of pieces

If you take one of those pieces and move it away from the corridor so that you’re just viewing it alone, does it look correct in the Lumen scene or is it still just a jumble of random triangles?

1 Like

Hey thanks for your answer. Sometimes I feel like this is a ghost forum :wink: Yes it was. I “fixed” it by changing the triangle percent in mesh settings. It was on 0 and now its on 1. Reflections are looking okay now as well (after changing the maxtracedistance) Still the lighting is not looking good. The skylight is just not being blocked. I guess Lumen cant handle big halls or I cant find the correct console command.

fixed mesh lumen view

with r.Lumen.MaxTraceDistance 10000.0

with r.Lumen.MaxTraceDistance 50000.0

“Lumen has an experimental Distant Scene representation to provide traces past the Surface Cache. It covers the range of 200 meters to 1 kilometer from the camera.”

So I guess thats whats causing a lot of my lighting issues. While it looks like a corridor its actually pretty big. ( 500 meters. ) I was trying to r.LumenScene.DistantScene 1 but it does not seem to do anything. Maybe its not build in. I guess I’m gonna scale down everything to as a workaround for now. =)