Lumen GI and Reflections feedback thread

did you watch the video i posted? the leaves are obviously moving. that’s wpo with nanite enabled. when wpo is disabled they wouldn’t move. still doesn’t change the fact that the shadow is static. that’s what’s causing this shadow glitch.

Yes, and your leaves may be moving because of your shader, but you may have “Evaluate WPO” checkbox unchecked, anyway.

Summary: If you enable WPO and disable Nanite, RT shadows work fine with non-Nanite meshes, but it doesn’t with Nanite ones.

Let’s make it easy:

dude… this’ about foliage, not static meshes.

setup: raytraced everything. manylights off (see wip note)

left: static mesh > shadow moves. right: foliage instance > shadow doesn’t move. nanite on > no wpo shadow moves.

wip: manylights currently has partial masked material support. the engine logo kinda works but those wpo tress do polygon shadows. but it’s WIP to integrate with raytraced direct light. same for volumetrics. i get it. :slight_smile:

anyway… enough derailment. back to work.

1 Like

This is somewhat of a tangent from the discussion, but has anyone had the time to do more in-depth testing of the new reflections denoiser? This is something that I personally have been looking for ever since 5.0 launched, so I am incredibly excited that we could get higher quality and greater content flexibility.

1 Like

Why is UE5.4 generell a peace of crap?

Hi guys,

Is there any way to get perfect mirror reflections with Lumen so far? Some hidden console commands? Hit lighting reflections still giving this messy look, no matter what settings I tweak for best quality:

what engine version are you on? 5.4 doesn’t have the latest graphics features, yet. it’ll improve soon™

I am on 5.3.2 currently.
5.5 will have a solution for it?

it’s work in progress, but… yes.

1 Like

Unfortunately, but GI in reflections can be quite low quality. You can try to disable it and instead use unshadowed skylight with r.Lumen.HardwareRayTracing.LightingMode 3 (I assume that you have hit lighting enabled). This will require some tweaking to get it right, but you won’t have noise in reflections.

3 Likes

So I was testing the new light function atlas feature (using 5.4) and noticed that RGB light functions only render the red channel into the surface cache. Just wondering if this is something that will be improved in the future?

EDIT
ANSWER: Sebastien Hillaire responded to my question in the tutorial thread confirming it was a bug that will be fixed :slight_smile:

quote from the tutorial

… it is possible to make the light function atlas account for colored light function materials. This can be enabled using r.LightFunctionAtlas.Format 1 (requires editor restart for shader recompilation). When set to 0 the R8 texture format is used, otherwise R8G8B8 is used.

(post deleted by author)

How does this interact with the lumen hit lighting GI system? Will that facilitate clean GI in reflections, or does it just resolve the limitations of the surface cache in first-bounce GI?

5.3.2 doesn’t do the clean reflection thing, yet. disabling surface cache in the reflection removes the noise. the unshadowed skylight is a global ambient boost to push light into the irradiance probes. basicly a “fake” gi/boosted irradiance in the interior. actually a very performant “cheat”. needs artist attention tho. tweaks.

Quite interested about seen a comparison. Unfortunately I have no my test scene available and I will need to wait to test by myself or to see the example posted by a good samaritan :innocent:

(post deleted by author)

I achieved no appreciable differences with this CVAR in my MRQ. The only viable solution at the moment for MRQ is Path Tracing but this takes a very long time! What tweaking are you talking about?


Hey does anyone know why I’m getting this weird reflection error in my level with hardware lumen.

This is unreal 5.4.2

The level is made up of a bunch of instance static meshes (not hierarchical). You can see one of the wall segments (which is still reflective) behind the reflection of the player character. Each one of these meshes has the same material which is a simple 0 roughness, 0 specular, 1 metalic.
I have set max reflection bounces to 3 in this case, but got the same effect on 8 (and it likely applies to everything inbetween). It didn’t happen when it was set to 1.

In case it is not clear what you are looking at, the should-be reflective walls have become grey with black specks in the reflection. Different segments will go in and out of this state depending on viewing angle, but not in any consistent way.

Does anyone have any experience with stuff like this?

That looks like a precision issue of some kind- are you far away from the world origin by chance?