Lumen and dense foliage

As illustrated in the image below, Lumen AO on trees with dense foliage gets unnaturally dark.

There are similar issues with DFAO, but those can be somewhat mitigated with the “Min Occlusion” and “Occlusion Tint” settings from the SkyLight. I couldn’t find anything along those lines for Lumen and post process settings alone aren’t enough to work around this issue. Even cranking up the sky light intensity does little to lighten the dark areas.

A setting to control the max occlusion would be useful, especially for more stylized games.

Lumen does not work well with foliage due to how it works off mesh distance fields which don’t take into account the opacity maps for the leaves

To be honest I find it hard to believe Epic would implement yet another global illumination method that doesn’t work with trees…
I mean we had global illumination methods that don’t work well with trees in UE4 already.
Surely there must be a way to finally make this work in UE5?
Hopefully at least by the time UE5 is out of Early Access.

The Hardware Ray Tracing option should work for foliage with Lumen, it would just have a bigger impact on performance.
Ultimately, without doing full ray tracing every fully dynamic lighting system is going to have its downsides because it has to cut corners somewhere

1 Like

I wonder if reducing the occlusion from foliage or masked materials in general would be possible. Either globally or on a per object basis, like a distance field opacity setting.

This gets particularly troublesome with forest scenes, occasionally resulting in complete darkness, as virtually no skylight makes it through the trees. I wonder if a solution is in the works for this, considering the majority of games out there feature some form of vegetation. I guess it explains why we only saw canyon scenes in the demos.

This is huge. How would you go around this? Can i just never use Lumen when I have trees?

You will have to use hardware based Lumen that has higher quality

Lumen foliage is supposedly coming in the full release, hypothetically it could be fine.

There’s other bugs and performance concerns with Lumen anyway so hopefully it will just get better in general.

Trees are very dark because subsurface scattering is not affected by lumen global illumination. You can get better results by just playing around with emissive.

I found a solution.
In the Post-Process Volume go to Color Grading, Shadows, and put the Contrast at around 0.85. It makes a huge difference!


5.0 is released but forest in sunny daytime are still pitch black, even with landscape now being used by lumen. Subsurface still looks broken so this amazing new feature is simply unusable if you work with a scene with foliage.

Hardware raytracing doesn’t support foliage or subsurface scattering, therefore it renders most foliage actors just black. Use software tracing for Lumen (Default). Running in software is also a lot more performant then hardware, especially for rendering large landscapes with foliage.
Also, be sure to have DirectX 12 selected as RHI.

We’re talking about lumen, not hardware raytracing. Subsurface still doesn’t work well with lumen and masked material are still used as opaque by lumen.
Epic knows it since one year and early access/preview, said it will be fixed for 5.0 release but it’s not (at least on main branch)

If you disable hardware raytracing, Lumen works much better on trees. I have a whole forest, and once I did that, the trees have the proper lighting with SSS. Same for umbrellas.
When I had hardware raytracing on, the areas under the trees were pitch black, especially if there were many of them upclose.
I’m using 5.0.1 btw.

I have the same lighting problem as well as performance issues with masked materials.

The developer said he fixed foliage lighting before 5.0 released but it was causing other weird behaviors so he reverted the change for the official release. It might be in 5.1, we just have to wait unfortunately.

I’ve been working with UE5_main lately, and I definitely know what you’re talking about. Fortunately, lumen just got per-hit support for masked materials yesterday, as well as other material improvements, so I think 5.1 will definitely be a lot better for foliage.

@ vfXander
Def got better with that suggestion. still have some blobby AO thing around some items, but def better.

Did you mean disable hardware as in use hardware when available = false, or turn off hardware support entirely? I don’t really want to compile all my shaders again rn and the former doesn’t seem to have any effect.

Turn “Use Hardware raytracing” off. Go to Settings, search “hardware” and you should find it there.