Download

LPV in 4.10?

Hi Everyone,

Has anyone got LPV going in 4.10?

I’ve got a little LPV test project that works just fine in 4.9 but when I open a copy of it (after converting in place) in 4.10 the LPV just doesn’t work

(yes, I did add the r.LightPropagationVolume=1 line to the consolevariables.ini file).

You probably have to enable it again like before

These are the settings I’m using in my projects to enable LPV. They work in 4.9 but they don’t work in 4.10:

 Lighting and shadows
• Config
o Open C:/program files/Unreal Engine/4.10/Engine/Config/ConsoleVariables.ini
o Add r.LightPropagationVolume = 1 under [Startup], save and restart UE4
• Setup Mesh Distance Fields
o Project settings > Rendering > Lighting > Generate mesh distance fields
• Directional light
o Set to movable
o Intensity to 10
o Turn on the Dynamic Indirect Lighting
o Dynamic Shadow Distance : 1000
o Num Dynamic Shadows : 4
o Distribution Exponent : 4.0
• Skylight
o Turn off cast shadows
• Editor settings
o Settings > Engine scalability settings > Epic

If there was something missing, it wouldn’t be working in 4.9. As far as I can tell that either means that there is something extra you have to do in 4.10 or it just isn’t working at all (atm).

I didn’t have any problem. I set “r.LightPropagationVolume=1” per project under [SystemSettings] in “Saved\Config\Windows\Engine.ini” rather than setting it globally in ConsoleVariables.ini, so I didn’t even have to re-enable LPV or redo any settings going from 4.9 to 4.10. I didn’t convert the 4.9 project in-place. I had the engine make the copy of the 4.9 project and then convert the copy to 4.10.

Hmmm… ok, it is still working, it’s just not showing up as strongly even though I haven’t changed the settings.

That’s good though I guess, at least now it’s just a matter of tweaking settings…

So this is the difference I’m getting between 4.8 and 4.10 (4.9 just crashes straight away).

As you can see, the first screenshot (from 4.8) shows the ground color showing up on the underside of the sphere, but the second (from 4.10) doesn’t.

51738e5742682b38d310415ce26aa59841722fdd.jpeg953b41b22a8393aadc5c205ba63d35820448fb47.jpeg

I actually quite like the 4.8 look, any tips on which settings to tweak to make 4.10 behave that way?

Here’s another couple of screenshots showing the same thing even more noticeably on a test character:

7805601d661262ce404327755c806a3988a726f3.jpeg
20151122_165926_post.jpg

What do you see when you enable Show > Visualize > Light Propagation Volume?

If you disable your skylight (uncheck “Affects World”), do your shadows turn pitch black?

Hi Joe, yes they do.

Hi Jacky, the LPV grid visualization shows up in 4.8 and 4.10, but it’s dimmer in 4.10.

It seems to me that the light is still bouncing but the color is not :confused:

If you get absolutely no detail in shadowed areas with just your directional light after disabling the skylight, it sounds like you’re not getting little or no indirect illumination from your directional light. I’ve no clue why that may be, but I’d first check the basics like the directional light’s indirect light intensity and LPV setting values in the post process volume. I’d start with all default values and keep the skylight disabled until it works.