Low Viewport FPS

Hey guys
Still new to Unreal coming from C4D, so I’m following a lot of tutorials.
I’m now following Materials Master Learning, which is recorded in January of 2018.
The instructor has consistent frame rates around 100FPS in the viewport.
I have shifting framerates around 30FPS suddenly dropping to 7FPS out of the blue - not necessarily when looking at expensive objects.

I’ve also experienced in another beginners project, that Sun light cause the viewport to make big artifact fully white instead of acting like the sun. -that works fine on my laptop.

My computer is quite beefy, so I don’t know what causes this.
-ASUS Prime Z490-P motherboard
-Intel Core i9 10900K 3,7Ghz (turbo speed 5,3Ghz)
-Gigabyte Geforce RTX 3090 24GB Turbo
-Windows Pro

Any good ideas?
-I’ve downloaded the latest display drivers from nVidia.
-other applications on the machine is Adobe Suite, MS Office, Dropbox (the project is not in the Dropbox folder though)

Thanks in advance!

Pretty difficult to troubleshoot without seeing the project, but it’s easy to tank your framerate by raytracing a relatively simple looking scene. Is it possible you have raytracing activated?

The sun making a ‘fully white artifact’ sounds like a combination of exposure and bloom settings not playing well together - but again, it’s basically a guess based on little information.

This doesnt tell us anything. We need to see what is going on there, literally.

Hey guys
I understand that it’s hard to imagine stuff like this - I was referring to this Unreal Course:

What I was hoping for was to get a general “ahh, but you need to turn this tick box on” – because I’m just following a course that is created from Unreal, not my own project, so I expect the courses to work on my machine.
However, I tried activating Raytracing and DirectX 12, and the FPS got up and has been steady at 100-120 FPS.
But then, why would I get bad framerates without raytracing?

I also have some weird banding where my viewport is split into three on the horizontal axis - any idea about that?


This is screen tearing, probably from lack of v-sync.

It’s fixed - so it was a combination of things: Lack of V-sync is one thing, an old HDMI cable another thing.
So I used “r.VSyncEditor 1” in the Output log and found out that the screen was only working at 30Hz because of the HDMI cable.
I changed to DisplayPort, and set “t.MaxFPS = 60” to lock the framerate to 60hz which is what the screen supports.
No screen tearing now - thank you for your help!