Download

Low textures

Hello. I have a problem with texture . In the EU4 it looks very weak , even though it is rendering the 2048/2048 . I can not increase the EU4 because I did Unwrapp in 3ds max . I want to make things look better because when you connect the normal map looks very bad. Does anyone have any idea? How i can change resolution of textures?

0e0e20c83f558996e9efc8aa5375ee67f51b7bfc.jpeg

Scale down the texture so that it starts tiling -> add a texture coordinate node in your material editor + connect it with the uv from the diffuse texture + change the values :slight_smile:

Yea, i add texture coordinate node but it’s unwrapp from 3ds max and changes make a black color on mesh from UVW template.

When i place material on mesh without unwrapp from 3ds max, it’s looking good, but only on some polygons. In other map is to high and this looking very bad.

I don’t understand clearly what you mean but you need to UVW unwrap your model in your 3d modeling software like Max and than simply import it as a FBX file into UE4. To make the material look better “not so big” simply tile it like fighter explained alreday. Actually there is not much you can do wrong…

Adik I understand everything 's just that when I change the texture coordinate value node same texture looks bad, because the template with 3ds max studio has a black colors .

Maybe i do something wrong.

What are you modeling? How large is the asset? What do the UVs and textures look like?

  1. I modeling architecture
  2. Is very big

ce4f1ffcb7e7baa720a3c0b11d8046b1b9d7753d.jpeg

If you aren’t doing any unique details on the texture, it would be better to use a tiling texture and playing with the texture coordinate to increase tiling. You can also use triplanar mapping instead to hide any edge seams. You can also use a big unique texture and have tiling texture overlaid on top, there’s a lot of ways around this issue.

Maybe my mistake was that I added in 3ds max modifier UVW Map . For each polygon is assigned the same “quantity” texture. I will now try without modifier.

EDIT : It doesn’t work :confused: without modifier looking bad.

I don’t have any idea how to fix it. For you is very easy, but I trying all options and no one doesn’t work.

You see on this picture. Top is “good” tilling, but on left side is very bad and i dont know how fix this.

dc13818e4fa76f5275c60023f264fd3c8568f733.jpeg

EDIT : I use Coordinate Index and it’s look better.

Could someone explain what the option Coordinate Index?

When you set up UV’s on your model, you’re telling the computer how to map textures to the 3D model. Set those up in 3ds Max. In UE4, you can use a texture coordinate in the Material Editor (plugged into the UVs of your texture) to make a texture tile many times over the surface. Tile the texture more to get better detail.

Thank you mariomguy , but I was concerned about Coordinate Index in Coordinated Texture Node . The initial value is 1 and I changed to 5 texture. Then I had a good spread .